summaryrefslogtreecommitdiffstats
path: root/openjpeg2_opj2.patch
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-03 12:20:43 +0200
committerRemi Collet <remi@remirepo.net>2019-04-03 12:20:43 +0200
commitabac16440e7dd7e9874c9f81547ba25c757268b0 (patch)
treeabb2310036ed11521fff57f4b37b29b490f9161b /openjpeg2_opj2.patch
parentc5b81e81a14554c7a808f5344bcd6aafa972d322 (diff)
Update to 2.3.1 from Fedora
Diffstat (limited to 'openjpeg2_opj2.patch')
-rw-r--r--openjpeg2_opj2.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/openjpeg2_opj2.patch b/openjpeg2_opj2.patch
new file mode 100644
index 0000000..4a531ad
--- /dev/null
+++ b/openjpeg2_opj2.patch
@@ -0,0 +1,12 @@
+diff -rupN openjpeg-2.3.1/src/bin/jp2/CMakeLists.txt openjpeg-2.3.1-new/src/bin/jp2/CMakeLists.txt
+--- openjpeg-2.3.1/src/bin/jp2/CMakeLists.txt 2019-04-02 14:45:15.000000000 +0200
++++ openjpeg-2.3.1-new/src/bin/jp2/CMakeLists.txt 2019-04-02 16:14:13.726252297 +0200
+@@ -44,6 +44,8 @@ endif()
+ # Loop over all executables:
+ foreach(exe opj_decompress opj_compress opj_dump)
+ add_executable(${exe} ${exe}.c ${common_SRCS})
++ string(REPLACE "opj_" "opj2_" exe2 ${exe})
++ set_target_properties(${exe} PROPERTIES OUTPUT_NAME ${exe2})
+ if(NOT ${CMAKE_VERSION} VERSION_LESS "2.8.12")
+ target_compile_options(${exe} PRIVATE ${OPENJP2_COMPILE_OPTIONS})
+ endif()