summaryrefslogtreecommitdiffstats
path: root/mongo-c-driver-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'mongo-c-driver-dev.spec')
-rw-r--r--mongo-c-driver-dev.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/mongo-c-driver-dev.spec b/mongo-c-driver-dev.spec
index 00df492..ad3cf74 100644
--- a/mongo-c-driver-dev.spec
+++ b/mongo-c-driver-dev.spec
@@ -21,6 +21,7 @@
# in MongoDB 3.2, and support is being removed in 3.4.
%global with_tests 0%{?_with_tests:1}
%endif
+%global with_tests 0
Name: mongo-c-driver
Summary: Client library written in C for MongoDB
@@ -32,6 +33,9 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/releases/download/%{version}%{?prever:-%{prever}}/%{gh_project}-%{version}%{?prever:-%{prever}}.tar.gz
+# https://github.com/mongodb/mongo-c-driver/pull/385
+Patch0: %{name}-api.patch
+
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(libbson-1.0) > %{bsonver}
%if 0%{?fedora} > 21 || 0%{?rhel} > 6
@@ -81,6 +85,7 @@ Documentation: http://api.mongodb.org/c/%{version}/
%prep
%setup -q -n %{gh_project}-%{version}%{?prever:-%{prever}}
+%patch0 -p1 -b .api
rm -r src/libbson
@@ -148,7 +153,7 @@ make check || ret=1
exit $ret
%else
-: check disabled, missing '--with tests' option
+make -C tests abicheck
%endif