summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-08 07:09:04 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-08 07:09:04 +0100
commit9febdad600d70a15e93b1f520eb9be7eb9c6fdf4 (patch)
tree96061c87fdd95a9766325452e0557fb673dcd997
parent39cd0653bd1b565785a8ad84c1864e44953a9b50 (diff)
mongo-c-driver: 1.3.0
-rw-r--r--mongo-c-driver.spec18
1 files changed, 15 insertions, 3 deletions
diff --git a/mongo-c-driver.spec b/mongo-c-driver.spec
index feef393..9166f2c 100644
--- a/mongo-c-driver.spec
+++ b/mongo-c-driver.spec
@@ -8,8 +8,8 @@
#
%global gh_owner mongodb
%global gh_project mongo-c-driver
-%global gh_commit 495cd3ffa9beade31c2b410eb5e9555c7db240e1
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_commit 495cd3ffa9beade31c2b410eb5e9555c7db240e1
+#global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151001
%global with_tests 0%{!?_without_tests:1}
%global libname libmongoc
@@ -18,7 +18,7 @@
Name: mongo-c-driver
Summary: Client library written in C for MongoDB
-Version: 1.2.0
+Version: 1.3.0
%if 0%{?gh_date}
Release: 0.6.%{gh_date}git%{gh_short}%{?dist}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
@@ -26,6 +26,8 @@ BuildRequires: libtool autoconf
%else
Release: 1%{?dist}
Source0: https://github.com/%{gh_owner}/%{gh_project}/releases/download/%{version}%{?prever:-%{prever}}/%{gh_project}-%{version}%{?prever:-%{prever}}.tar.gz
+# https://jira.mongodb.org/browse/CDRIVER-1039
+Source1: https://raw.githubusercontent.com/mongodb/mongo-c-driver/master/doc/mallard2man.py
%endif
License: ASL 2.0
Group: System Environment/Libraries
@@ -80,6 +82,7 @@ a MongoDB Server.
autoreconf -fvi -I build/autotools
%else
%setup -q -n %{gh_project}-%{version}%{?prever:-%{prever}}
+install -m 0755 %{SOURCE1} doc/
%endif
# Ensure we are using system library
@@ -104,6 +107,11 @@ make install DESTDIR=%{buildroot}
rm %{buildroot}%{_libdir}/*la
rm -r %{buildroot}%{_datadir}/doc/
+# drop "generic" man pages, avoid conflicts
+# https://jira.mongodb.org/browse/CDRIVER-1039
+rm %{buildroot}/%{_mandir}/man3/[a-l]*
+rm %{buildroot}/%{_mandir}/man3/ma*
+rm %{buildroot}/%{_mandir}/man3/[t-u]*
%check
@@ -159,6 +167,10 @@ exit $ret
%changelog
+* Tue Dec 8 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- Update to 1.3.0
+- open https://jira.mongodb.org/browse/CDRIVER-1040 - ABI breaks
+
* Wed Oct 14 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0