summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-16 14:16:05 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-16 14:16:05 +0200
commit8ce380570073b9e65d69797ceb01e61c1c90a9ae (patch)
tree83b107701663a33de226c548b733c154a6bef100
parent77345cceebfeb6f174556d2d2fd65002f4239bd6 (diff)
mongo-c-driver: fix rpmlint warning
-rw-r--r--mongo-c-driver-crypto.patch2
-rw-r--r--mongo-c-driver.spec1
2 files changed, 2 insertions, 1 deletions
diff --git a/mongo-c-driver-crypto.patch b/mongo-c-driver-crypto.patch
index e3cf7da..c9d1d94 100644
--- a/mongo-c-driver-crypto.patch
+++ b/mongo-c-driver-crypto.patch
@@ -11,7 +11,7 @@ diff -up ./src/mongoc/mongoc-ssl.c.old ./src/mongoc/mongoc-ssl.c
- * @STRENGTH - Sort ciphers based on strength */
- SSL_CTX_set_cipher_list (ctx, "HIGH:!EXPORT:!aNULL@STRENGTH");
+ /* See https://fedoraproject.org/wiki/Packaging:CryptoPolicies */
-+ SSL_CTX_set_cipher_list (ctx, "PROFILE=SYSTEM");
++ /* SSL_CTX_set_cipher_list (ctx, "PROFILE=SYSTEM"); */
/* If renegotiation is needed, don't return from recv() or send() until it's successful.
* Note: this is for blocking sockets only. */
diff --git a/mongo-c-driver.spec b/mongo-c-driver.spec
index 2e6f3bf..3ae85fb 100644
--- a/mongo-c-driver.spec
+++ b/mongo-c-driver.spec
@@ -32,6 +32,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/releases/download/%{vers
# Enforce system crypto policies
# https://fedoraproject.org/wiki/Packaging:CryptoPolicies
+# https://jira.mongodb.org/browse/CDRIVER-1231
Patch0: %{name}-crypto.patch
BuildRequires: pkgconfig(openssl)