summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-31 19:36:33 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-31 19:36:33 +0200
commit70d20f0775ad0088599a1140320243abc7d3e82e (patch)
tree718950861318729b7c7e8b0411411c65ba13a9e9
parent1eee5c6bea51ca3d85a9b420b2f1527b9be07eae (diff)
mongo-c-driver: 1.2.0beta
-rw-r--r--mongo-c-driver-upstream.patch22
-rw-r--r--mongo-c-driver.spec27
2 files changed, 44 insertions, 5 deletions
diff --git a/mongo-c-driver-upstream.patch b/mongo-c-driver-upstream.patch
new file mode 100644
index 0000000..421af38
--- /dev/null
+++ b/mongo-c-driver-upstream.patch
@@ -0,0 +1,22 @@
+From 5cd61e3170cfe81e4bc9be12d4b2d86e4e1ca53e Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Mon, 31 Aug 2015 18:48:15 +0200
+Subject: [PATCH] allow driver to use mongoc-log-private
+
+---
+ src/mongoc/mongoc-log-private.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mongoc/mongoc-log-private.h b/src/mongoc/mongoc-log-private.h
+index fa02960..49bf1cc 100644
+--- a/src/mongoc/mongoc-log-private.h
++++ b/src/mongoc/mongoc-log-private.h
+@@ -17,7 +17,7 @@
+ #ifndef MONGOC_LOG_PRIVATE_H
+ #define MONGOC_LOG_PRIVATE_H
+
+-#if !defined (MONGOC_INSIDE) && !defined (MONGOC_COMPILATION)
++#if !defined (MONGOC_INSIDE) && !defined (MONGOC_COMPILATION) && !defined (MONGOC_I_AM_A_DRIVER)
+ # error "Only <mongoc.h> can be included directly."
+ #endif
+
diff --git a/mongo-c-driver.spec b/mongo-c-driver.spec
index f47bf2f..19f4d90 100644
--- a/mongo-c-driver.spec
+++ b/mongo-c-driver.spec
@@ -8,12 +8,18 @@
#
%global gh_owner mongodb
%global gh_project mongo-c-driver
-%global gh_commit 38fc65a0f4b2b17d71ee71683c93aa84718a6733
+%global gh_commit 8189e90f1ad29fc4a133985452aeec54efd9bb4a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20150413
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+#global gh_date 20150810
+%if 0%{?fedora} >= 23
+# mongodb-server broken in f23
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
%global libname libmongoc
%global libver 1.0
+%global prever beta
Name: mongo-c-driver
Summary: Client library written in C for MongoDB
@@ -23,13 +29,15 @@ Release: 0.1.%{gh_date}git%{gh_short}%{?dist}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
BuildRequires: libtool autoconf
%else
-Release: 1%{?dist}
+Release: 0.2.%{prever}%{?dist}
Source0: https://github.com/%{gh_owner}/%{gh_project}/releases/download/%{version}%{?prever:-%{prever}}/%{gh_project}-%{version}%{?prever:-%{prever}}.tar.gz
%endif
License: ASL 2.0
Group: System Environment/Libraries
URL: https://github.com/%{gh_owner}/%{gh_project}
+Patch0: %{name}-upstream.patch
+
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(libbson-1.0)
%if 0%{?fedora} > 21 || 0%{?rhel} > 6
@@ -79,7 +87,13 @@ a MongoDB Server.
%setup -q -n %{gh_project}-%{gh_commit}
autoreconf -fvi -I build/autotools
%else
-%setup -q
+%setup -q -n %{gh_project}-%{version}%{?prever:-%{prever}}
+%endif
+
+%patch0 -p1 -b .upstream
+
+%if 0%{?rhel} == 6
+sed -e '/GCC diagnostic/d' -i src/mongoc/mongoc-matcher-op.c
%endif
# Ensure we are using system library
@@ -159,6 +173,9 @@ exit $ret
%changelog
+* Mon Aug 31 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-0.2.beta
+- Upstream version 1.2.0beta
+
* Wed May 20 2015 Remi Collet <remi@fedoraproject.org> - 1.1.6-1
- Upstream version 1.1.6