summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-15 16:44:24 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-15 16:44:24 +0100
commit6a28698755c436510a4c4993441baf37e5ab1f63 (patch)
tree7845043924dbf6c67aa4ddcc2742b1231f7bbf3e
parent046e0e1c680f4ed95f6285eaaa2456c54f98bee7 (diff)
mongo-c-driver: 1.3.4
-rw-r--r--mongo-c-driver-pr314.patch61
-rw-r--r--mongo-c-driver.spec14
2 files changed, 7 insertions, 68 deletions
diff --git a/mongo-c-driver-pr314.patch b/mongo-c-driver-pr314.patch
deleted file mode 100644
index 16c467d..0000000
--- a/mongo-c-driver-pr314.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 077c04640ce1f199a6f91052291d622ca6825995 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 29 Feb 2016 16:56:54 +0100
-Subject: [PATCH] allow to skip online tests
-
----
- tests/test-libmongoc.c | 6 ++++++
- tests/test-libmongoc.h | 1 +
- tests/test-mongoc-topology.c | 4 ++--
- 3 files changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test-libmongoc.c b/tests/test-libmongoc.c
-index 6a36e05..a06f60f 100644
---- a/tests/test-libmongoc.c
-+++ b/tests/test-libmongoc.c
-@@ -1209,6 +1209,12 @@ int test_framework_skip_if_max_version_version_less_than_4 (void)
- }
-
-
-+int test_framework_skip_if_offline (void)
-+{
-+ return getenv("MONGOC_TEST_OFFLINE") ? 0 : 1;
-+}
-+
-+
- int
- main (int argc,
- char *argv[])
-diff --git a/tests/test-libmongoc.h b/tests/test-libmongoc.h
-index 5ccf2d1..9d2bba3 100644
---- a/tests/test-libmongoc.h
-+++ b/tests/test-libmongoc.h
-@@ -61,6 +61,7 @@ int test_framework_skip_if_windows (void);
- int test_framework_skip_if_not_mongos (void);
- int test_framework_skip_if_not_replset (void);
- int test_framework_skip_if_not_single (void);
-+int test_framework_skip_if_offline (void);
-
- typedef struct _debug_stream_stats_t {
- mongoc_client_t *client;
-diff --git a/tests/test-mongoc-topology.c b/tests/test-mongoc-topology.c
-index fa225df..86fba9a 100644
---- a/tests/test-mongoc-topology.c
-+++ b/tests/test-mongoc-topology.c
-@@ -750,7 +750,7 @@ test_connect_timeout_try_once_false(void)
-
-
- static void
--test_multiple_selection_errors (void)
-+test_multiple_selection_errors (void *context)
- {
- const char *uri = "mongodb://doesntexist,example.com:2/?replicaSet=rs"
- "&connectTimeoutMS=100";
-@@ -811,6 +811,6 @@ test_topology_install (TestSuite *suite)
- TestSuite_Add (suite, "/Topology/connect_timeout/pooled", test_connect_timeout_pooled);
- TestSuite_Add (suite, "/Topology/connect_timeout/single/try_once", test_connect_timeout_single);
- TestSuite_Add (suite, "/Topology/connect_timeout/single/try_once_false", test_connect_timeout_try_once_false);
-- TestSuite_Add (suite, "/Topology/multiple_selection_errors", test_multiple_selection_errors);
-+ TestSuite_AddFull (suite, "/Topology/multiple_selection_errors", test_multiple_selection_errors, NULL, NULL, test_framework_skip_if_offline);
- TestSuite_Add (suite, "/Topology/invalid_server_id", test_invalid_server_id);
- }
diff --git a/mongo-c-driver.spec b/mongo-c-driver.spec
index 32a7dfe..fab826b 100644
--- a/mongo-c-driver.spec
+++ b/mongo-c-driver.spec
@@ -29,17 +29,14 @@
Name: mongo-c-driver
Summary: Client library written in C for MongoDB
-Version: 1.3.3
-Release: 2%{?dist}
+Version: 1.3.4
+Release: 1%{?dist}
License: ASL 2.0
Group: System Environment/Libraries
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/releases/download/%{version}%{?prever:-%{prever}}/%{gh_project}-%{version}%{?prever:-%{prever}}.tar.gz
-# https://github.com/mongodb/mongo-c-driver/pull/314
-Patch0: %{name}-pr314.patch
-
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(libbson-1.0)
%if 0%{?fedora} > 21 || 0%{?rhel} > 6
@@ -91,7 +88,6 @@ Documentation: http://api.mongodb.org/c/%{version}/
%setup -q -n %{gh_project}-%{version}%{?prever:-%{prever}}
rm -r src/libbson
-%patch0 -p1 -b .pr314
%build
@@ -142,7 +138,7 @@ mongod \
: Run the test suite
ret=0
-export MONGOC_TEST_OFFLINE=1
+export MONGOC_TEST_OFFLINE=on
make check || ret=1
: Cleanup
@@ -177,6 +173,10 @@ exit $ret
%changelog
+* Tue Mar 15 2016 Remi Collet <remi@fedoraproject.org> - 1.3.4-1
+- update to 1.3.4
+- drop patch merged upstream
+
* Mon Feb 29 2016 Remi Collet <remi@fedoraproject.org> - 1.3.3-2
- cleanup for review
- move libraries in "libs" sub-package