summaryrefslogtreecommitdiffstats
path: root/libzip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libzip.spec')
-rw-r--r--libzip.spec34
1 files changed, 24 insertions, 10 deletions
diff --git a/libzip.spec b/libzip.spec
index bec3ccd..fefcd17 100644
--- a/libzip.spec
+++ b/libzip.spec
@@ -10,7 +10,7 @@
#
%global libname libzip
%global soname 5
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%if 0%{?rhel} == 6
%global with_xz 0
%else
@@ -22,7 +22,7 @@ Name: %{libname}
%else
Name: %{libname}%{soname}
%endif
-Version: 1.7.1
+Version: 1.7.2
Release: 1%{?dist}
Summary: C library for reading, creating, and modifying zip archives
@@ -30,12 +30,15 @@ License: BSD
URL: https://libzip.org/
Source0: https://libzip.org/download/libzip-%{version}.tar.xz
+Patch0: libzip-gnuinstalldirs.patch
+Patch1: libzip-privlibs.patch
+
BuildRequires: gcc
-BuildRequires: zlib-devel
+BuildRequires: zlib-devel >= 1.1.2
BuildRequires: bzip2-devel
BuildRequires: openssl-devel
%if %{with_xz}
-BuildRequires: xz-devel
+BuildRequires: xz-devel >= 5.2
%endif
%if 0%{?rhel} == 6 || 0%{?rhel} == 7
BuildRequires: cmake3 >= 3.0.2
@@ -116,21 +119,25 @@ The %{name}-tools package provides command line tools split off %{name}:
%prep
%setup -q -n %{libname}-%{version}
+%patch0 -p1 -b .gnuinstalldirs
+%patch1 -p1 -b .privlib
# unwanted in package documentation
rm INSTALL.md
-%if ! %{with_xz}
-sed -e '/store_to_xz.test/d;/xz_to_store.test/d' -i regress/CMakeLists.txt
-%endif
-
%build
-%if 0%{?rhel} == 6 || 0%{?rhel} == 7
# drop skipped test which make test suite fails (cmake issue ?)
sed -e '/clone-fs-/d' \
+%if ! %{with_xz}
+ -e '/store_to_xz.test/d;/xz_to_store.test/d' \
+%endif
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
-e '/add_from_stdin/d' \
+%endif
-i regress/CMakeLists.txt
+
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
sed -e 's/COMMAND cmake /COMMAND cmake3 /' -i CMakeLists.txt regress/CMakeLists.txt
%cmake3 \
%else
@@ -161,7 +168,7 @@ make install DESTDIR=%{buildroot} INSTALL='install -p'
%check
-%if %{with_tests}
+%if %{with tests}
make check
%else
: Test suite disabled
@@ -198,6 +205,13 @@ make check
%changelog
+* Mon Jul 13 2020 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+- fix installation layout using patch from
+ https://github.com/nih-at/libzip/pull/190
+- fix pkgconfig usability using patch from
+ https://github.com/nih-at/libzip/pull/191
+
* Sun Jun 14 2020 Remi Collet <remi@remirepo.net> - 1.7.1-1
- update to 1.7.1