summaryrefslogtreecommitdiffstats
path: root/libzip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libzip.spec')
-rw-r--r--libzip.spec23
1 files changed, 22 insertions, 1 deletions
diff --git a/libzip.spec b/libzip.spec
index 7c7182d..9d5424a 100644
--- a/libzip.spec
+++ b/libzip.spec
@@ -11,13 +11,18 @@
%global libname libzip
%global soname 5
%global with_tests 0%{!?_without_tests:1}
+%if 0%{?rhel} == 6
+%global with_xz 0
+%else
+%global with_xz 0
+%endif
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
Name: %{libname}
%else
Name: %{libname}%{soname}
%endif
-Version: 1.5.2
+Version: 1.6.0
Release: 1%{?dist}
Summary: C library for reading, creating, and modifying zip archives
@@ -29,6 +34,9 @@ BuildRequires: gcc
BuildRequires: zlib-devel
BuildRequires: bzip2-devel
BuildRequires: openssl-devel
+%if %{with_xz}
+BuildRequires: xz-devel
+%endif
%if 0%{?rhel} == 6 || 0%{?rhel} == 7
BuildRequires: cmake3 >= 3.0.2
%else
@@ -112,6 +120,10 @@ The %{name}-tools package provides command line tools split off %{name}:
# unwanted in package documentation
rm INSTALL.md
+%if ! %{with_xz}
+sed -e '/store_to_xz.test/d;/xz_to_store.test/d' -i regress/CMakeLists.txt
+%endif
+
%build
%if 0%{?rhel} == 6 || 0%{?rhel} == 7
@@ -128,6 +140,11 @@ sed -e 's/COMMAND cmake /COMMAND cmake3 /' -i CMakeLists.txt regress/CMakeLists.
-DENABLE_OPENSSL:BOOL=ON \
-DENABLE_WINDOWS_CRYPTO:BOOL=OFF \
-DENABLE_BZIP2:BOOL=ON \
+%if %{with_xz}
+ -DENABLE_LZMA:BOOL=ON \
+%else
+ -DENABLE_LZMA:BOOL=OFF \
+%endif
-DBUILD_TOOLS:BOOL=ON \
-DBUILD_REGRESS:BOOL=ON \
-DBUILD_EXAMPLES:BOOL=OFF \
@@ -178,6 +195,10 @@ make check
%changelog
+* Fri Jan 24 2020 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- enable lzma support (excepted on EL-6)
+
* Tue Mar 12 2019 Remi Collet <remi@remirepo.net> - 1.5.2-1
- update to 1.5.2
- add all explicit cmake options to ensure openssl is used