summaryrefslogtreecommitdiffstats
path: root/libzip.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-30 08:18:40 +0100
committerRemi Collet <remi@remirepo.net>2017-12-30 08:18:40 +0100
commitc11462288d96842ebadecd57731e4f589e49dc77 (patch)
treeecb285693336899a24e6b5511c57ba57eb27bd4b /libzip.spec
parent71a358d094539c5b3daf157618c7f634792655e7 (diff)
update to 1.4.0
switch to cmake add upstream patch for lib64
Diffstat (limited to 'libzip.spec')
-rw-r--r--libzip.spec40
1 files changed, 28 insertions, 12 deletions
diff --git a/libzip.spec b/libzip.spec
index 4a6a9a1..b0329e2 100644
--- a/libzip.spec
+++ b/libzip.spec
@@ -17,7 +17,7 @@ Name: %{libname}
%else
Name: %{libname}%{soname}
%endif
-Version: 1.3.2
+Version: 1.4.0
Release: 1%{?dist}
Group: System Environment/Libraries
Summary: C library for reading, creating, and modifying zip archives
@@ -26,8 +26,18 @@ License: BSD
URL: https://libzip.org/
Source0: https://libzip.org/download/libzip-%{version}.tar.xz
+# drop RPATH from installed binaries
+Patch0: libzip-rpath.patch
+# allow path customization (lib64)
+Patch1: libzip-upstream.patch
+
BuildRequires: zlib-devel
BuildRequires: bzip2-devel
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+BuildRequires: cmake3 >= 3.0.2
+%else
+BuildRequires: cmake >= 3.0.2
+%endif
# Needed to run the test suite
# find regress/ -type f | /usr/lib/rpm/perl.req
# find regress/ -type f | /usr/lib/rpm/perl.prov
@@ -104,17 +114,21 @@ The %{name}-tools package provides command line tools split off %{name}:
%prep
%setup -q -n %{libname}-%{version}
+%patch1 -p1 -b .upstream
+%patch0 -p1 -b .rpm
-# Avoid lib64 rpaths (FIXME: recheck this on newer releases)
-%if "%{_libdir}" != "/usr/lib"
-sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
-#autoreconf -f -i
-%endif
+# unwanted in package documentation
+rm INSTALL.md
%build
-%configure \
- --disable-static
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+# drop skipped test which make test suite fails (cmake issue ?)
+sed -e '/clone-fs-/d' -i regress/CMakeLists.txt
+%cmake3 .
+%else
+%cmake .
+%endif
make %{?_smp_mflags}
@@ -122,9 +136,6 @@ make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot} INSTALL='install -p'
-## unpackaged files
-rm -fv %{buildroot}%{_libdir}/lib*.la
-
%check
%if %{with_tests}
@@ -151,7 +162,7 @@ make check
%{_mandir}/man1/zip*
%files devel
-%doc API-CHANGES AUTHORS THANKS *.md
+%doc AUTHORS THANKS *.md
%{_includedir}/zip.h
%{_includedir}/zipconf*.h
%{_libdir}/libzip.so
@@ -162,6 +173,11 @@ make check
%changelog
+* Sat Dec 30 2017 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- switch to cmake
+- add upstream patch for lib64
+
* Mon Nov 20 2017 Remi Collet <remi@remirepo.net> - 1.3.2-1
- update to 1.3.2