summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-08-08 10:58:49 +0200
committerRemi Collet <fedora@famillecollet.com>2013-08-08 10:58:49 +0200
commit78ef147bbb6d9964f90207014412c8395e53e2a4 (patch)
treebf50025c107666d7922321f1429c2ce640d2e25d
parent382118baf6b037764e0bc4fdb17ee6089c93f4af (diff)
libzip: sync with rawhide
-rw-r--r--libzip.spec137
-rw-r--r--zipconf.h26
2 files changed, 79 insertions, 84 deletions
diff --git a/libzip.spec b/libzip.spec
index 4cbe3c5..ea5f0fa 100644
--- a/libzip.spec
+++ b/libzip.spec
@@ -1,21 +1,23 @@
-Name: libzip2
-Version: 0.10
-Release: 2%{?dist}
-Summary: C library for reading, creating, and modifying zip archives
-
-Group: Applications/File
-License: BSD
-URL: http://www.nih.at/libzip/index.html
-Source0: http://www.nih.at/libzip/libzip-%{version}.tar.bz2
-# to handle multiarch heder, ex from mysql-devel package
-Source1: zipconf.h
-
-Patch0: libzip-0.10-php.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: automake libtool
+
+%define multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9
+
+Name: libzip
+Version: 0.10.1
+Release: 7%{?dist}
+Summary: C library for reading, creating, and modifying zip archives
+
+License: BSD
+URL: http://www.nih.at/libzip/index.html
+Source0: http://www.nih.at/libzip/libzip-%{version}.tar.bz2
+
+#BuildRequires: automake libtool
BuildRequires: zlib-devel
-Requires: %{name}-libs%{?_isa} = %{version}-%{release}
+
+# to handle multiarch headers, ex from mysql-devel package
+Source1: zipconf.h
+
+# fonctionnal changes from php bundled library
+Patch0: libzip-0.10-php.patch
%description
@@ -25,86 +27,105 @@ other zip archives. Changes made without closing the archive can be reverted.
The API is documented by man pages.
%package devel
-Summary: Development files for %{name}
-Group: Development/Libraries
-Requires: %{name}-libs%{?_isa} = %{version}-%{release}
-
+Summary: Development files for %{name}
+Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
-%package libs
-Summary: Tools files for %{name}
-Group: System Environment/Libraries
-
-%description libs
-The %{name}-tools package contains tools that use %{name}.
-
-
%prep
-%setup -q -n libzip-%{version}
+%setup -q
%patch0 -p1 -b .forphp
# Avoid lib64 rpaths (FIXME: recheck this on newer releases)
-#if "%{_libdir}" != "/usr/lib"
-#sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
-autoreconf -f -i
-#endif
+%if "%{_libdir}" != "/usr/lib"
+sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
+#autoreconf -f -i
+%endif
%build
-%configure --disable-static
+%configure \
+ --disable-static
+
make %{?_smp_mflags}
%install
-rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
-find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
-# Handle multiarch headers
-mv $RPM_BUILD_ROOT%{_libdir}/libzip/include/zipconf.h \
- $RPM_BUILD_ROOT%{_includedir}/zipconf_$(uname -i).h
-install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/zipconf.h
+make install DESTDIR=%{buildroot} INSTALL='install -p'
-%clean
-rm -rf $RPM_BUILD_ROOT
+## unpackaged files
+rm -fv %{buildroot}%{_libdir}/lib*.la
+## FIXME: someday fix consumers of libzip to properly handle
+## header @ %%{_libdir}/libzip/include/zipconf.h -- rex
+%ifarch %{multilib_archs}
+ln -s ../%{_lib}/libzip/include/zipconf.h \
+ %{buildroot}%{_includedir}/zipconf-%{__isa_bits}.h
+install -D -m644 -p %{SOURCE1} %{buildroot}%{_includedir}/zipconf.h
+%else
+ln -s ../%{_lib}/libzip/include/zipconf.h \
+ %{buildroot}%{_includedir}/zipconf.h
+%endif
-%post -p /sbin/ldconfig
+%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
-
%files
-%defattr(-,root,root,-)
+%doc AUTHORS NEWS README THANKS TODO
%{_bindir}/zipcmp
%{_bindir}/zipmerge
%{_bindir}/ziptorrent
-%{_mandir}/man1/*zip*
-
-%files libs
-%defattr(-,root,root,-)
-%doc AUTHORS NEWS README THANKS TODO
%{_libdir}/libzip.so.2*
+%{_mandir}/man1/*zip*
%files devel
-%defattr(-,root,root,-)
-%{_includedir}/zip*.h
+%{_includedir}/zip.h
+%{_includedir}/zipconf*.h
+%dir %{_libdir}/libzip
+%{_libdir}/libzip/include
%{_libdir}/libzip.so
%{_libdir}/pkgconfig/libzip.pc
%{_mandir}/man3/*zip*
%changelog
-* Sat Feb 04 2012 Remi Collet <Fedora@FamilleCollet.com> 0.10-2
-- improves multiarch headers (ex from MySQL)
+* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Mon Oct 15 2012 Remi Collet <remi@fedoraproject.org> - 0.10.1-5
+- fix typo in multiarch (#866171)
-* Sun Mar 20 2011 Remi Collet <Fedora@FamilleCollet.com> 0.10-1
+* Wed Sep 05 2012 Rex Dieter <rdieter@fedoraproject.org> 0.10.1-4
+- Warning about conflicting contexts for /usr/lib64/libzip/include/zipconf.h versus /usr/include/zipconf-64.h (#853954)
+
+* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Tue Jul 10 2012 Rex Dieter <rdieter@fedoraproject.org> 0.10.1-2
+- spec cleanup, better multilib fix
+
+* Wed Mar 21 2012 Remi Collet <remi@fedoraproject.org> - 0.10.1-1
+- update to 0.10.1 (security fix only)
+- fixes for CVE-2012-1162 and CVE-2012-1163
+
+* Sun Mar 04 2012 Remi Collet <remi@fedoraproject.org> - 0.10-2
+- try to fix ARM issue (#799684)
+
+* Sat Feb 04 2012 Remi Collet <remi@fedoraproject.org> - 0.10-1
- update to 0.10
-- rename to libzip2 and split libs in sub package
+- apply patch with changes from php bundled lib (thanks spot)
+- handle multiarch headers (ex from MySQL)
+
+* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.3-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
diff --git a/zipconf.h b/zipconf.h
deleted file mode 100644
index 89a6da1..0000000
--- a/zipconf.h
+++ /dev/null
@@ -1,26 +0,0 @@
-/*
- * Kluge to support multilib installation of both 32 and 64-bit RPMS:
- * we need to arrange that header files that appear in both RPMs are
- * identical. Hence, this file is architecture-independent and calls
- * in an arch-dependent file that will appear in just one RPM.
- *
- * To avoid breaking arches not explicitly supported by Fedora, we
- * use this indirection file *only* on known multilib arches.
- */
-#if defined(__x86_64__)
-#include "zipconf_x86_64.h"
-#elif defined(__i386__)
-#include "zipconf_i386.h"
-#elif defined(__ppc64__) || defined(__powerpc64__)
-#include "zipconf_ppc64.h"
-#elif defined(__ppc__) || defined(__powerpc__)
-#include "zipconf_ppc.h"
-#elif defined(__s390x__)
-#include "zipconf_s390x.h"
-#elif defined(__s390__)
-#include "zipconf_s390.h"
-#elif defined(__sparc__) && defined(__arch64__)
-#include "zipconf_sparc64.h"
-#elif defined(__sparc__)
-#include "zipconf_sparc.h"
-#endif