summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-28 19:20:59 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-28 19:20:59 +0100
commit324248940b4457c7ca2cd2e13a917e19a52bd567 (patch)
treec294dbe0c718e7bdd4e33f30c2ee3c4aa40cbecf
parent0aa163e31f14b16d3d3f3cc347095028ac4a37b5 (diff)
libzip-last 1.1
-rw-r--r--libzip-build.patch11
-rw-r--r--libzip.spec16
2 files changed, 25 insertions, 2 deletions
diff --git a/libzip-build.patch b/libzip-build.patch
new file mode 100644
index 0000000..5736b17
--- /dev/null
+++ b/libzip-build.patch
@@ -0,0 +1,11 @@
+diff -up src/ziptool.c.old src/ziptool.c
+--- src/ziptool.c.old 2016-01-28 14:19:37.026356371 +0100
++++ src/ziptool.c 2016-01-28 14:19:43.394384005 +0100
+@@ -53,6 +53,7 @@
+ #include "compat.h"
+
+ zip_source_t *source_hole_create(const char *, int flags, zip_error_t *);
++extern int optopt;
+
+ typedef enum {
+ SOURCE_TYPE_NONE,
diff --git a/libzip.spec b/libzip.spec
index ec70cf8..60db008 100644
--- a/libzip.spec
+++ b/libzip.spec
@@ -26,8 +26,8 @@ Name: %{libname}-last
%else
Name: %{libname}
%endif
-Version: 1.0.1
-Release: 3%{?dist}
+Version: 1.1
+Release: 1%{?dist}
Group: System Environment/Libraries
Summary: C library for reading, creating, and modifying zip archives
@@ -37,6 +37,9 @@ Source0: http://www.nih.at/libzip/libzip-%{version}.tar.xz
# to handle multiarch headers, ex from mysql-devel package
Source1: zipconf.h
+# fix undefined optopt
+Patch0: %{libname}-build.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
# Needed to run the test suite
@@ -97,11 +100,14 @@ Obsoletes: %{libname}-last-tools <= %{version}
The %{name}-tools package provides command line tools split off %{name}:
- zipcmp
- zipmerge
+- ziptool
%prep
%setup -q -n %{libname}-%{version}
+%patch0 -p0 -b .build
+
# Avoid lib64 rpaths (FIXME: recheck this on newer releases)
%if "%{_libdir}" != "/usr/lib"
sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
@@ -157,6 +163,7 @@ make check
%defattr(-,root,root,-)
%{_bindir}/zipcmp
%{_bindir}/zipmerge
+%{_bindir}/ziptool
%{_mandir}/man1/zip*
%files devel
@@ -174,6 +181,11 @@ make check
%changelog
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 1.1-1
+- update to 1.1
+- new ziptool command
+- add fix for undefined optopt in ziptool.c (upstream)
+
* Thu Jan 14 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-3
- libzip obsoletes libzip-last