summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-25 10:29:25 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-25 10:29:25 +0200
commitb8ce629047fbd5fa3ec662f61d7d087316cc248a (patch)
tree4c7b5bd041544c6858201d0861067ba6f67368bb
libui: 20161023 git snapshot (new packahe)
-rw-r--r--Makefile4
-rw-r--r--libui.spec99
2 files changed, 103 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/libui.spec b/libui.spec
new file mode 100644
index 0000000..cb83f01
--- /dev/null
+++ b/libui.spec
@@ -0,0 +1,99 @@
+# remirepo/fedora spec file for libui
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%global gh_commit 0870a3065ed219c3dd2332972a6ffb3b95ce199a
+%global gh_date 20161023
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner andlabs
+%global gh_project libui
+%global libname libui
+%global soname 0
+
+Name: %{libname}
+Summary: Simple and portable GUI library
+Version: 0
+Release: 0.2.%{gh_date}git%{gh_short}%{?dist}
+License: MIT
+Group: System Environment/Libraries
+
+URL: https://github.com/andlabs/libui
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+%if 0%{?rhel}
+BuildRequires: cmake3 >= 3.1.0
+%else
+BuildRequires: cmake >= 3.1.0
+%endif
+BuildRequires: gtk3-devel
+
+
+%description
+Simple and portable (but not inflexible) GUI library in C that uses the native
+GUI technologies of each platform it supports.
+
+
+%package devel
+Summary: Header files and development libraries for %{name}
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+This package contains the header files and development libraries
+for %{name}.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+%if 0%{?rhel}
+%cmake3
+%else
+%cmake
+%endif
+
+make %{_smp_mflags}
+
+
+%install
+: Library
+install -Dm 755 out/%{libname}.so.%{soname} %{buildroot}%{_libdir}/%{libname}.so.%{soname}
+ln -s %{libname}.so.%{soname} %{buildroot}%{_libdir}/%{libname}.so
+
+: Headers
+for header in ui.h ui_unix.h uitable.h; do
+ install -Dpm 644 $header %{buildroot}%{_includedir}/$header
+done
+
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+
+%files
+%license LICENSE
+%{_libdir}/%{libname}.so.%{soname}*
+
+
+%files devel
+%doc *.md
+%doc examples
+%{_libdir}/%{libname}.so
+%{_includedir}/ui*.h
+
+
+%changelog
+* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 0-0.2.20161023git0870a30
+- update to latest upstream snapshot for pecl/ui
+
+* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 0-0.1.alpha3.1
+- initial package
+