summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-28 09:09:23 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-28 09:09:23 +0200
commitb498b42bbbca6dc2ce774bf5acd9d7176067c26f (patch)
tree31a1a07b1db404dcf4774e1aa3bd5f31cb2fd0c3
parentd11d624f920c48f83986cb727af186945d0479e7 (diff)
libsodium-last: rename and update to 1.0.0 (abi compatible with 0.7.0)
-rw-r--r--Makefile4
-rw-r--r--libsodium-last.spec (renamed from libsodium.spec)57
2 files changed, 50 insertions, 11 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/libsodium.spec b/libsodium-last.spec
index a2cf329..45860de 100644
--- a/libsodium.spec
+++ b/libsodium-last.spec
@@ -1,10 +1,21 @@
-Name: libsodium
-Version: 0.7.0
+%global libname libsodium
+
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 7
+# Standard build
+Name: %{libname}
+%else
+# Build for parallel install
+Name: %{libname}-last
+%endif
+Version: 1.0.0
Release: 1%{?dist}
Summary: The Sodium crypto library
License: ISC
URL: http://libsodium.org/
-Source0: http://download.libsodium.org/libsodium/releases/%{name}-%{version}.tar.gz
+Source0: http://download.libsodium.org/libsodium/releases/%{libname}-%{version}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
%description
Sodium is a new, easy-to-use software library for encryption, decryption,
@@ -18,47 +29,71 @@ The same cannot be said of NIST curves, where the specific origins of certain
constants are not described by the standards. And despite the emphasis on
higher security, primitives are faster across-the-board than most
implementations of the NIST standards.
+%if "%{libname}" != "%{name}"
+This package can be installed beside system %{libname}.
+%endif
+
%package devel
Summary: Development files for %{name}
-Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+%if "%{libname}" != "%{name}"
+Conflicts: %{libname}-devel < %{version}
+Provides: %{libname}-devel = %{version}-%{release}
+Provides: %{libname}-devel%{?_isa} = %{version}-%{release}
+%endif
%description devel
This package contains libraries and header files for
developing applications that use %{name} libraries.
+%if "%{libname}" != "%{name}"
+This package can't be installed with system %{libname}-devel.
+%endif
+
%prep
-%setup -q
+%setup -q -n %{libname}-%{version}
%build
%configure --disable-static --disable-silent-rules
-%make_build
+make %{_smp_mflags}
+
%install
%make_install
-find %{buildroot} -name '*.la' -delete -print
+rm -f %{buildroot}%{_libdir}/%{libname}.la
+
%check
make check
+
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
+
%files
-%doc LICENSE
-%{_libdir}/libsodium.so.*
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%{_libdir}/%{libname}.so.13*
%files devel
%doc AUTHORS ChangeLog README.markdown THANKS
%doc test/default/*.{c,h}
%{_includedir}/sodium.h
%{_includedir}/sodium/
-%{_libdir}/libsodium.so
-%{_libdir}/pkgconfig/libsodium.pc
+%{_libdir}/%{libname}.so
+%{_libdir}/pkgconfig/%{libname}.pc
+
%changelog
+* Sun Sep 28 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- rename to libsodium-last (fedora <= 20, el <= 6)
+- update to 1.0.0 (abi is now stable)
+- fix license handling
+
* Sun Aug 24 2014 Christopher Meng <rpm@cicku.me> - 0.7.0-1
- Update to 0.7.0