summaryrefslogtreecommitdiffstats
path: root/librdkafka.spec
diff options
context:
space:
mode:
Diffstat (limited to 'librdkafka.spec')
-rw-r--r--librdkafka.spec29
1 files changed, 26 insertions, 3 deletions
diff --git a/librdkafka.spec b/librdkafka.spec
index 5ce1d6d..b290c5c 100644
--- a/librdkafka.spec
+++ b/librdkafka.spec
@@ -7,14 +7,14 @@
# Please, preserve the changelog entries
#
%global libname librdkafka
-%global gh_commit 3bdf2d05fad1ef699910f7f9e7152c58aa24375e
+%global gh_commit 39796d359898c07ea422849e6d7cd34cd13ec466
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner edenhill
%global gh_project %{libname}
%global oldsoname 1
%global newsoname 101
-%global upstream_version 1.4.4
+%global upstream_version 1.5.0
#global upstream_prever RC1
Name: %{libname}%{oldsoname}php
@@ -41,8 +41,20 @@ BuildRequires: pkgconfig(libsasl2)
BuildRequires: pkgconfig(zlib)
BuildRequires: pkgconfig(liblz4)
BuildRequires: pkgconfig(libzstd)
+
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+%if 0%{?rhel} == 7
+%global dtsenable source /opt/rh/devtoolset-7/enable
+BuildRequires: devtoolset-7-toolchain
+%else
+%global dtsenable source /opt/rh/devtoolset-6/enable
+BuildRequires: devtoolset-6-toolchain
+%endif
+%else
BuildRequires: gcc-c++
-%if 0%{?fedora} >= 28 || 0%{?rhel} >=8
+%endif
+
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 7
BuildRequires: python3
%else
BuildRequires: python
@@ -82,7 +94,12 @@ cp -pr examples rpmdocs/examples
%build
+%{?dtsenable}
+gcc --version
+
%configure \
+ --enable-zlib \
+ --enable-zstd \
--enable-lz4 \
--enable-lz4-ext \
--enable-ssl \
@@ -93,6 +110,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make install DESTDIR=%{buildroot}
rm %{buildroot}%{_libdir}/*.a
@@ -124,6 +143,10 @@ rm -r %{buildroot}%{_datadir}/doc/%{libname}
%changelog
+* Mon Jul 20 2020 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- use GCC 6 on EL-6, GCC 7 on EL-7
+
* Sun Jun 21 2020 Remi Collet <remi@remirepo.net> - 1.4.4-1
- update to 1.4.4