summaryrefslogtreecommitdiffstats
path: root/librdkafka.spec
diff options
context:
space:
mode:
Diffstat (limited to 'librdkafka.spec')
-rw-r--r--librdkafka.spec23
1 files changed, 15 insertions, 8 deletions
diff --git a/librdkafka.spec b/librdkafka.spec
index a3ad7ce..3eca2c9 100644
--- a/librdkafka.spec
+++ b/librdkafka.spec
@@ -1,23 +1,23 @@
# remirepo/fedora spec file for librdkafka
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global libname librdkafka
-%global gh_commit 849c066b559950b02e37a69256f0cb7b04381d0e
+%global gh_commit 8695b9d63ac0fe1b891b511d5b36302ffc84d4e2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner edenhill
%global gh_project %{libname}
-%global upstream_version 0.11.6
+%global upstream_version 1.0.0
#global upstream_prever RC1
Name: %{libname}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Group: System Environment/Libraries
Summary: Apache Kafka C/C++ client library
@@ -26,11 +26,12 @@ License: BSD and MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
-BuildRequires: openssl-devel
-BuildRequires: cyrus-sasl-devel
-BuildRequires: zlib-devel
BuildRequires: libstdc++-devel
-BuildRequires: lz4-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig(libsasl2)
+BuildRequires: pkgconfig(zlib)
+BuildRequires: pkgconfig(liblz4)
+BuildRequires: pkgconfig(libzstd)
BuildRequires: gcc-c++
%if 0%{?fedora} >= 28 || 0%{?rhel} >=8
BuildRequires: python3
@@ -69,7 +70,9 @@ cp -pr examples rpmdocs/examples
%build
%configure \
--enable-lz4 \
+ --enable-lz4-ext \
--enable-ssl \
+ --enable-gssapi \
--enable-sasl
make %{?_smp_mflags}
@@ -107,6 +110,10 @@ rm %{buildroot}%{_libdir}/pkgconfig/*static.pc
### NOTICE: available in EPEL-7 so not in remi
%changelog
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+- add dependency on libzstd
+
* Wed Dec 12 2018 Remi Collet <remi@remirepo.net> - 0.11.6-2
- cleanup for EL-8