summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-25 12:09:34 +0200
committerRemi Collet <remi@remirepo.net>2019-09-25 12:09:34 +0200
commit223e6be1b1cebd9b1d39a9d2f191e87012f497ce (patch)
tree1926b4f247af4ff04d0f9af352966870d9b3a513
import from EL 7.7
-rw-r--r--libpaper-1.1.20-automake_1.10.patch11
-rw-r--r--libpaper-1.1.23-debianbug475683.patch12
-rw-r--r--libpaper-useglibcfallback.patch80
-rw-r--r--libpaper.spec174
4 files changed, 277 insertions, 0 deletions
diff --git a/libpaper-1.1.20-automake_1.10.patch b/libpaper-1.1.20-automake_1.10.patch
new file mode 100644
index 0000000..55be567
--- /dev/null
+++ b/libpaper-1.1.20-automake_1.10.patch
@@ -0,0 +1,11 @@
+--- libpaper-1.1.20/aclocal.m4.orig 2006-01-07 16:10:33.000000000 -0500
++++ libpaper-1.1.20/aclocal.m4 2007-07-09 09:09:07.000000000 -0400
+@@ -6433,7 +6433,7 @@ AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api
+ # Call AM_AUTOMAKE_VERSION so it can be traced.
+ # This function is AC_REQUIREd by AC_INIT_AUTOMAKE.
+ AC_DEFUN([AM_SET_CURRENT_AUTOMAKE_VERSION],
+- [AM_AUTOMAKE_VERSION([1.9.6])])
++ [AM_AUTOMAKE_VERSION([1.10])])
+
+ # AM_AUX_DIR_EXPAND -*- Autoconf -*-
+
diff --git a/libpaper-1.1.23-debianbug475683.patch b/libpaper-1.1.23-debianbug475683.patch
new file mode 100644
index 0000000..36135d0
--- /dev/null
+++ b/libpaper-1.1.23-debianbug475683.patch
@@ -0,0 +1,12 @@
+diff -up libpaper-1.1.23+nmu1/lib/paperspecs.BAD libpaper-1.1.23+nmu1/lib/paperspecs
+--- libpaper-1.1.23+nmu1/lib/paperspecs.BAD 2008-08-22 16:49:16.000000000 -0400
++++ libpaper-1.1.23+nmu1/lib/paperspecs 2008-08-22 16:49:25.000000000 -0400
+@@ -40,7 +40,7 @@ c5 162 229 mm
+ c6 114 162 mm
+ c7 81 114 mm
+ c8 57 81 mm
+-DL 312 624
++DL 110 220 mm
+ Comm10 297 684
+ Monarch 279 540
+ archE 2592 3456
diff --git a/libpaper-useglibcfallback.patch b/libpaper-useglibcfallback.patch
new file mode 100644
index 0000000..8a80f78
--- /dev/null
+++ b/libpaper-useglibcfallback.patch
@@ -0,0 +1,80 @@
+diff -up libpaper-1.1.24/lib/paper.c.useglibcfallback libpaper-1.1.24/lib/paper.c
+--- libpaper-1.1.24/lib/paper.c.useglibcfallback 2010-04-24 08:12:11.000000000 -0400
++++ libpaper-1.1.24/lib/paper.c 2010-04-24 12:04:59.549538425 -0400
+@@ -20,6 +20,9 @@
+
+ #include <unistd.h>
+
++#include <locale.h>
++#include <langinfo.h>
++
+ #include "paper.h"
+
+ struct paper {
+@@ -108,6 +111,27 @@ in PAPERCONFVAR, fall-back to the old be
+ }
+
+ const char* defaultpapername(void) {
++#if defined(LC_PAPER) && defined(_GNU_SOURCE)
++
++#define NL_PAPER_GET(x) \
++ ((union { char *string; unsigned int word; })nl_langinfo(x)).word
++
++#define PT_TO_MM(v) (unsigned int)((v * 2.54 * 10 / 72) + 0.5)
++
++ const struct paper* pp;
++
++ unsigned int w = NL_PAPER_GET(_NL_PAPER_WIDTH);
++ unsigned int h = NL_PAPER_GET(_NL_PAPER_HEIGHT);
++
++ for (pp = paperfirst(); pp; pp = papernext(pp)) {
++ if (
++ PT_TO_MM(pp->pswidth) == w &&
++ PT_TO_MM(pp->psheight) == h
++ ) {
++ return pp->name;
++ }
++ }
++#endif
+ return PAPERSIZE;
+ }
+
+diff -up libpaper-1.1.24/man/paperconf.1.in.useglibcfallback libpaper-1.1.24/man/paperconf.1.in
+--- libpaper-1.1.24/man/paperconf.1.in.useglibcfallback 2004-01-19 23:35:04.000000000 -0500
++++ libpaper-1.1.24/man/paperconf.1.in 2010-04-24 12:03:56.866532268 -0400
+@@ -48,10 +48,12 @@ looking in order at the
+ .B @PAPERSIZEVAR@
+ environment variable, at the contents of the file specified by the
+ .B @PAPERCONFVAR@
+-environment variable, at the contects of
++environment variable, at the contents of the file
+ .B @PAPERCONF@
+-or by using
+-.B letter
++, consulting the values controlled by the
++.B LC_PAPER
++locale setting, or by using
++.B @PAPERSIZE@
+ as a fall-back value if none of the other alternatives are successful.
+ By default, width and height of the paper are printed in PostScript points.
+ .SH OPTIONS
+diff -up libpaper-1.1.24/src/paperconf.c.useglibcfallback libpaper-1.1.24/src/paperconf.c
+--- libpaper-1.1.24/src/paperconf.c.useglibcfallback 2007-09-26 02:13:38.000000000 -0400
++++ libpaper-1.1.24/src/paperconf.c 2010-04-24 12:03:56.867538135 -0400
+@@ -13,6 +13,7 @@
+ #include <errno.h>
+
+ #include <paper.h>
++#include <locale.h>
+
+
+ /* needed for GNU/Hurd */
+@@ -99,6 +100,8 @@ int main(int argc, char** argv)
+
+ const char* progname;
+
++ setlocale(LC_ALL, "");
++
+ progname = strrchr(*argv, '/');
+ if (progname) {
+ ++progname;
diff --git a/libpaper.spec b/libpaper.spec
new file mode 100644
index 0000000..3c36ebd
--- /dev/null
+++ b/libpaper.spec
@@ -0,0 +1,174 @@
+%global nmu +nmu1
+
+Name: libpaper
+Version: 1.1.24
+Release: 8%{?dist}
+Summary: Library and tools for handling papersize
+Group: System Environment/Libraries
+License: GPLv2
+URL: http://packages.qa.debian.org/libp/libpaper.html
+Source0: http://ftp.debian.org/debian/pool/main/libp/libpaper/%{name}_%{version}%{nmu}.tar.gz
+# Filed upstream as:
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496126
+Patch0: libpaper-1.1.20-automake_1.10.patch
+# Upstream bug:
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=475683
+Patch1: libpaper-1.1.23-debianbug475683.patch
+# Filed upstream as:
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481213
+Patch2: libpaper-useglibcfallback.patch
+BuildRequires: libtool, gettext, gawk
+
+%description
+The paper library and accompanying files are intended to provide a
+simple way for applications to take actions based on a system- or
+user-specified paper size. This release is quite minimal, its purpose
+being to provide really basic functions (obtaining the system paper name
+and getting the height and width of a given kind of paper) that
+applications can immediately integrate.
+
+%package devel
+Summary: Headers/Libraries for developing programs that use libpaper
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+This package contains headers and libraries that programmers will need
+to develop applications which use libpaper.
+
+%prep
+%setup -q -n %{name}-%{version}%{nmu}
+%patch0 -p1 -b .automake110
+%patch1 -p1 -b .dlfix
+%patch2 -p1 -b .useglibcfallback
+libtoolize
+
+%build
+touch AUTHORS NEWS
+aclocal
+autoconf
+automake -a
+%configure --disable-static
+# Disable rpath
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+make %{?_smp_mflags}
+
+%install
+make DESTDIR=$RPM_BUILD_ROOT install
+rm $RPM_BUILD_ROOT%{_libdir}/*.la
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
+echo '# Simply write the paper name. See papersize(5) for possible values' > $RPM_BUILD_ROOT%{_sysconfdir}/papersize
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/libpaper.d
+for i in cs da de es fr gl hu it ja nl pt_BR sv tr uk vi; do
+ mkdir -p $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES/;
+ msgfmt debian/po/$i.po -o $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES/%{name}.mo;
+done
+%find_lang %{name}
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files -f %{name}.lang
+%doc COPYING ChangeLog README
+%config(noreplace) %{_sysconfdir}/papersize
+%dir %{_sysconfdir}/libpaper.d
+%{_bindir}/paperconf
+%{_libdir}/libpaper.so.*
+%{_sbindir}/paperconfig
+%{_mandir}/man1/*
+%{_mandir}/man5/*
+%{_mandir}/man8/*
+
+%files devel
+%{_includedir}/paper.h
+%{_libdir}/libpaper.so
+%{_mandir}/man3/*
+
+%changelog
+* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.1.24-8
+- Mass rebuild 2014-01-24
+
+* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.1.24-7
+- Mass rebuild 2013-12-27
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.24-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.24-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.24-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Tue May 17 2011 Tom Callaway <spot@fedoraproject.org> - 1.1.24-3
+- bump to nmu1
+
+* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.24-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sat Apr 24 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.24-1
+- update to 1.1.24
+
+* Thu Mar 4 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.23-7
+- update to 1.1.23+nmu2
+
+* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.23-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.23-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Mon Feb 16 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.23-4
+- run libtoolize to fix build with newer libtool
+- disable rpath
+
+* Fri Aug 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.1.23-3
+- update to nmu1
+- apply patch to fix imprecise definition of DL format
+- apply patch so that when no config is present, libpaper will fallback through
+ LC_PAPER before giving up and using Letter
+
+* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.23-2
+- Autorebuild for GCC 4.3
+
+* Tue Feb 19 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.23-1
+- 1.1.23
+
+* Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.22-1.1
+- missing BR: gawk
+
+* Thu Aug 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.22-1
+- bump, no real changes of note, rebuild for ppc32
+- license fix, v2 only
+
+* Mon Jul 09 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.21-1.1
+- BR: libtool
+
+* Mon Jul 09 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.21-1
+- bump to 1.1.21
+- fix automake bug (bz 247458)
+
+* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 1.1.20-5
+ - rebuilt for unwind info generation, broken in gcc-4.1.1-21
+
+* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-4
+- remove aclocal call
+
+* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-3
+- fix FC-4 with aclocal call
+- move man3 pages to -devel
+- don't set default, just put comment in conf file
+- own /etc/libpaper.d
+- use debian/NEWS
+- include the meager translations
+- use --disable-static
+
+* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-2
+- nuke static lib
+- own /etc/papersize
+- fix mixed spaces/tabs rpmlint warning
+
+* Sat Sep 23 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.20-1
+- initial package for Fedora Extras