summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-24 10:46:16 +0200
committerRemi Collet <remi@remirepo.net>2021-06-24 10:46:16 +0200
commitc7a0d7a2b2e1a43d4184a6c891289b3d64c90010 (patch)
tree72767db32e5f71cd9660f75fd385792a5eb2c172
parent2720acbdd4ec5fa0dd80fbf2c6192adcfe016d09 (diff)
update to 1.1.0
rename libmemcached to libmemcached-awesome-tools rename libmemcached-libs to libmemcached-awesome rename libmemcached-devel to libmemcached-awesome-devel
-rw-r--r--libmemcached-awesome.spec (renamed from libmemcached-last.spec)120
-rwxr-xr-xstrip-hsieh.sh24
2 files changed, 70 insertions, 74 deletions
diff --git a/libmemcached-last.spec b/libmemcached-awesome.spec
index 711f19b..bc3c04d 100644
--- a/libmemcached-last.spec
+++ b/libmemcached-awesome.spec
@@ -1,7 +1,4 @@
-# remirepo spec file for libmemcached-opt
-# renamed for parallel installation, from:
-#
-# Fedora spec file for libmemcached
+# remirepo spec file for libmemcached-awesome
#
# Copyright (c) 2009-2021 Remi Collet
# License: CC-BY-SA
@@ -15,24 +12,23 @@
%global libname libmemcached
# libmemcached >= 1.0.16 have soname 11
-%if 0%{?rhel} == 7
+%if 0%{?rhel} == 7 || 0%{?rhel} == 8
%global move_to_opt 1
-Name: %{libname}-opt
-%global _prefix /opt/%{libname}
+%global _prefix /opt/remi/%{name}
%global __arch_install_post /bin/true
%else
%global move_to_opt 0
-Name: %{libname}
%endif
-%global gh_commit 000bce60d1b956664898d77db980952d01849b8c
+%global gh_commit 0ff88be3322a493773956028d4022d995f3cb193
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner m6w6
+%global gh_owner awesomized
%global gh_project libmemcached
%global upstream_version 1.1.0
-%global upstream_prever beta3
+#global upstream_prever beta3
+Name: %{libname}-awesome
Summary: Client library and command line tools for memcached server
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}
@@ -42,8 +38,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{g
%if 0%{?rhel} == 7
BuildRequires: cmake3 >= 3.9
-%global dtsenable source /opt/rh/devtoolset-7/enable
-BuildRequires: devtoolset-7-toolchain
+%global dtsenable source /opt/rh/devtoolset-9/enable
+BuildRequires: devtoolset-9-toolchain
BuildRequires: python-sphinx
%else
BuildRequires: cmake >= 3.9
@@ -59,55 +55,72 @@ BuildRequires: systemtap-sdt-devel
BuildRequires: libevent-devel > 2
Provides: bundled(bobjenkins-hash)
-Requires: %{name}-libs%{?_isa} = %{version}-%{release}
+%if ! %{move_to_opt}
+# package rename
+Obsoletes: %{libname}-libs < 1.1
+Provides: %{libname}-libs = %{version}-%{release}
+Provides: %{libname}-libs%{?_isa} = %{version}-%{release}
+%endif
%description
-libmemcached is a C/C++ client library and tools for the memcached server
-(http://memcached.org/). It has been designed to be light on memory
-usage, and provide full access to server side methods.
+%{name} is a C/C++ client library and tools for the memcached
+server (http://memcached.org/). It has been designed to be light
+on memory usage, and provide full access to server side methods.
-It also implements several command line tools:
-
-memaslap Load testing and benchmarking a server
-memcapable Checking a Memcached server capibilities and compatibility
-memcat Copy the value of a key to standard output
-memcp Copy data to a server
-memdump Dumping your server
-memerror Translate an error code to a string
-memexist Check for the existance of a key
-memflush Flush the contents of your servers
-memparse Parse an option string
-memping Test to see if a server is available.
-memrm Remove a key(s) from the server
-memslap Generate testing loads on a memcached cluster
-memstat Dump the stats of your servers to standard output
-memtouch Touches a key
+This is a resurrection of the original work from Brian Aker at libmemcached.org.
%package devel
Summary: Header files and development libraries for %{name}
+
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: pkgconfig
Requires: cyrus-sasl-devel%{?_isa}
+%if ! %{move_to_opt}
+# package rename
+Obsoletes: %{libname}-devel < 1.1
+Provides: %{libname}-devel = %{version}-%{release}
+Provides: %{libname}-devel%{?_isa} = %{version}-%{release}
+%endif
%description devel
This package contains the header files and development libraries
for %{name}. If you like to develop programs using %{name},
you will need to install %{name}-devel.
-Documentation: https://m6w6.github.io/libmemcached/
+Documentation: https://awesomized.github.io/libmemcached
-%package libs
-Summary: %{libname} libraries
+%package tools
+Summary: %{name} tools
-%description libs
-This package contains the %{libname} libraries version %{version}.
-%if "%{libname}" != "%{name}"
-This package is designed to be installed beside %{libname}.
+Requires: %{name}%{?_isa} = %{version}-%{release}
+%if ! %{move_to_opt}
+# package rename
+Obsoletes: %{libname} < 1.1
+Provides: %{libname} = %{version}-%{release}
+Provides: %{libname}%{?_isa} = %{version}-%{release}
%endif
+%description tools
+This package contains the %{libname}-awesome command line tools:
+
+memaslap Load testing and benchmarking a server
+memcapable Checking a Memcached server capibilities and compatibility
+memcat Copy the value of a key to standard output
+memcp Copy data to a server
+memdump Dumping your server
+memerror Translate an error code to a string
+memexist Check for the existance of a key
+memflush Flush the contents of your servers
+memparse Parse an option string
+memping Test to see if a server is available.
+memrm Remove a key(s) from the server
+memslap Generate testing loads on a memcached cluster
+memstat Dump the stats of your servers to standard output
+memtouch Touches a key
+
%if %{move_to_opt}
# Filter in the /opt installation
@@ -121,6 +134,7 @@ This package is designed to be installed beside %{libname}.
%setup -q -n %{gh_project}-%{gh_commit}
# drop test hanging in mock
+# and requiring some memcached build options
if [ "$(id -un)" != "remi" ]; then
rm test/tests/memcached/sasl.cpp
fi
@@ -161,9 +175,9 @@ make %{?_smp_mflags}
make install DESTDIR=%{buildroot}
%endif
-mv %{buildroot}%{_datadir}/libmemcached/example.cnf support
+mv %{buildroot}%{_datadir}/%{name}/example.cnf support
-rm -r %{buildroot}%{_datadir}/doc/libmemcached/
+rm -r %{buildroot}%{_datadir}/doc/%{name}/
%check
@@ -180,12 +194,12 @@ make test
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
-%post libs -p /sbin/ldconfig
-%postun libs -p /sbin/ldconfig
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
%endif
-%files
+%files tools
%if %{move_to_opt}
%dir %{_bindir}
%dir %{_mandir}/man1
@@ -193,9 +207,8 @@ make test
%{_bindir}/mem*
%{_mandir}/man1/mem*
-%files libs
+%files
%{!?_licensedir:%global license %%doc}
-%doc ChangeLog-*.md
%license LICENSE
%if %{move_to_opt}
%dir %{_prefix}
@@ -210,7 +223,8 @@ make test
%files devel
%doc example
-%doc BUGS.md CONTRIBUTING.md README.md
+%doc *.md
+%doc AUTHORS
%doc support/example.cnf
%if %{move_to_opt}
%dir %{_includedir}
@@ -230,7 +244,7 @@ make test
%{_libdir}/libmemcachedprotocol.so
%{_libdir}/libmemcachedutil.so
%{_libdir}/pkgconfig/libmemcached.pc
-%{_libdir}/cmake/libmemcached
+%{_libdir}/cmake/%{name}
%{_datadir}/aclocal/ax_libmemcached.m4
%{_mandir}/man3/libmemcached*
%{_mandir}/man3/libhashkit*
@@ -239,10 +253,16 @@ make test
%changelog
+* Thu Jun 24 2021 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- rename libmemcached to libmemcached-awesome-tools
+- rename libmemcached-libs to libmemcached-awesome
+- rename libmemcached-devel to libmemcached-awesome-devel
+
* Thu Apr 15 2021 Remi Collet <remi@remirepo.net> - 1.1.0~beta3-1
- update to 1.1.0-beta3
-* Mon Dec 29 2020 Remi Collet <remi@remirepo.net> - 1.1.0~beta2-1
+* Tue Dec 29 2020 Remi Collet <remi@remirepo.net> - 1.1.0~beta2-1
- update to 1.1.0-beta2
* Sat Dec 26 2020 Remi Collet <remi@remirepo.net> - 1.1.0~beta1-3
diff --git a/strip-hsieh.sh b/strip-hsieh.sh
deleted file mode 100755
index eeb3d0f..0000000
--- a/strip-hsieh.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/bash -ex
-
-ver=$1
-
-tdir=`mktemp -d tmpXXXXXX`
-pushd $tdir
-
-tar -xzf ../libmemcached-$ver.tar.gz
-
-pushd libmemcached-$ver
- rm libhashkit/hsieh.cc
- grep -r 'azillionmonkeys' . && exit 1
-popd
-
-rm -f ../libmemcached-$ver-exhsieh.tar.gz
-tar --no-xattrs -czf ../libmemcached-$ver-exhsieh.tar.gz libmemcached-$ver
-
-tar -tzf ../libmemcached-$ver.tar.gz | sort > manifest-before
-tar -tzf ../libmemcached-$ver-exhsieh.tar.gz | sort > manifest-after
-
-diff -u manifest-before manifest-after || true
-
-popd
-rm -rf $tdir