summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-13 09:18:43 +0200
committerRemi Collet <remi@remirepo.net>2019-08-13 09:18:43 +0200
commitc478e090134ca219dcc7d8088aa550c3cee663b1 (patch)
tree1fb2625f7bbeffb138d4038312f997a4368e9b3c
parentb74dfd5479b12dd702294fbd3c6ad1a86a11f48a (diff)
import 7.7 changes
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--libkdcraw.spec12
3 files changed, 23 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..b0b29b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
+abi_dumps/
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/libkdcraw.spec b/libkdcraw.spec
index 5eb4372..1d15bdb 100644
--- a/libkdcraw.spec
+++ b/libkdcraw.spec
@@ -1,7 +1,7 @@
Name: libkdcraw
Summary: A C++ interface around LibRaw library
Version: 4.10.5
-Release: 5%{?dist}
+Release: 7%{?dist}
# libkdcraw is GPLv2+,
# LibRaw(bundled) is LGPLv2
# demosaic-pack GPLv2+ GPLv3+ (addons to libraw)
@@ -12,6 +12,9 @@ Source0: https://download.kde.org/Attic/4.10.5/src/%{name}-%{version}.tar.xz
# drop bundled libraw and use the system LibRaw
Patch1: libkdcraw-4.10.5-use-system-libraw.patch
+# port to build against LibRAW-0.19
+patch2: libkdcraw-4.10.5-api-change-in-LibRAW-0.19.patch
+
# fix libjpeg detection for libjpeg-turbo, hopefully upstreamable
# (the hack to add jpeg_mem_src from RawSpeed to LibRaw might not be though)
Patch50: libkdcraw-4.10.0-libjpeg-turbo.patch
@@ -48,6 +51,7 @@ Requires: kdelibs4-devel
%prep
%setup -q
%patch1 -p1 -b .using-system-libraw
+%patch2 -p1 -b .api-change-in-LibRAW-0.19
%patch50 -p1 -b .libjpeg-turbo
# upstream patches
@@ -106,6 +110,12 @@ fi
%changelog
+* Wed Feb 13 2019 Than Ngo <than@redhat.com> - 4.10.5-7
+- Related: #1670708 - rebuilt against rebased LibRaw 0.19.2
+
+* Wed Jan 30 2019 Than Ngo <than@redhat.com> - 4.10.5-6
+- Resolves: #1670708 - dependencies issue with rebased LibRaw 0.19.2
+
* Wed Apr 18 2018 Than Ngo <than@redhat.com> - 4.10.5-5
- Resolves: #1557171, #1557189, #1558954
use the system LibRaw