summaryrefslogtreecommitdiffstats
path: root/libhandlebars.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libhandlebars.spec')
-rw-r--r--libhandlebars.spec23
1 files changed, 13 insertions, 10 deletions
diff --git a/libhandlebars.spec b/libhandlebars.spec
index 185822d..0446634 100644
--- a/libhandlebars.spec
+++ b/libhandlebars.spec
@@ -6,8 +6,12 @@
#
# Please, preserve the changelog entries
#
+
+# Workaround to https://github.com/jbboehr/handlebars.c/issues/81
+%global _hardened_ldflags %nil
+
%global libname libhandlebars
-%global gh_commit 9863359d28fa57cabe5494a00453ff12e8581d56
+%global gh_commit 91c94d0264c3cd2f0544876ca35cb2dc70b98ad1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner jbboehr
%global gh_project handlebars.c
@@ -23,8 +27,8 @@
%global mspec_project spec
Name: %{libname}
-Version: 0.6.4
-Release: 4%{?dist}
+Version: 0.7.0
+Release: 1%{?dist}
Summary: Handlebars C library
License: LGPLv2+
@@ -33,11 +37,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_
Source1: https://github.com/%{hspec_owner}/%{hspec_project}/archive/%{hspec_commit}/%{hspec_project}-%{hspec_short}.tar.gz
Source2: https://github.com/%{mspec_owner}/%{mspec_project}/archive/%{mspec_commit}/%{mspec_project}-%{mspec_short}.tar.gz
-# For GCC 10
-Patch0: %{libname}-gcc10.patch
-# Fox new check library
-Patch1: %{libname}-check.patch
-
BuildRequires: gcc
BuildRequires: autoconf
BuildRequires: automake
@@ -83,8 +82,6 @@ This package provides handlebarsc command line tool split off %{libname}.
%prep
%setup -qn %{gh_project}-%{gh_commit} -a1 -a2
-%patch0 -p1 -b .gcc10
-%patch1 -p1 -b .newcheck
mkdir spec
mv %{hspec_project}-%{hspec_commit} spec/handlebars
@@ -130,6 +127,12 @@ make test
%changelog
+* Fri Apr 17 2020 Remi Collet <remi@remirepo.net> - 0.7.0-1
+- update to 0.7.0
+- drop patches merged upstream
+- open https://github.com/jbboehr/handlebars.c/issues/81
+ _hardened_ldflags break build
+
* Wed Feb 19 2020 Remi Collet <remi@remirepo.net> - 0.6.4-4
- add fix for GCC 10 from
https://github.com/jbboehr/handlebars.c/pull/76