summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libdigidocpp.spec8
1 files changed, 8 insertions, 0 deletions
diff --git a/libdigidocpp.spec b/libdigidocpp.spec
index d05934d..1a33429 100644
--- a/libdigidocpp.spec
+++ b/libdigidocpp.spec
@@ -139,6 +139,14 @@ make %{?_smp_mflags} -C %{_target_platform}
make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
+%check
+# Minimal load test for the PHP extension
+php -n \
+ -d extension_dir=%{_target_platform}/src/php \
+ -d extension=digidoc.so -m \
+ | grep digidoc
+
+
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig