summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-08 17:18:06 +0100
committerRemi Collet <remi@php.net>2021-11-08 17:18:06 +0100
commit39ba10214121bde5ff2a6b02a24978348b61f399 (patch)
tree0f8c5d3656144c618a78fb13f739e908fbef836d
parent6a9ab8d339ce15ca52be2b6bf73f1990123c7aae (diff)
new package
-rw-r--r--libcgif-pc.patch29
-rw-r--r--libcgif.spec11
2 files changed, 36 insertions, 4 deletions
diff --git a/libcgif-pc.patch b/libcgif-pc.patch
new file mode 100644
index 0000000..eecbab4
--- /dev/null
+++ b/libcgif-pc.patch
@@ -0,0 +1,29 @@
+From e79e12f868e16da7c2a3726ad13205b1dd62ca94 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 8 Nov 2021 17:10:29 +0100
+Subject: [PATCH] fix #24 define project version
+
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 8da6bf6..28eb50d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,6 +1,7 @@
+ project(
+ 'libcgif',
+ 'c',
++ version : '0.0.1',
+ license : 'MIT',
+ default_options : ['c_std=c99'],
+ )
+@@ -9,7 +10,6 @@ lib = library(
+ 'cgif',
+ 'cgif.c',
+ soversion : '0',
+- version : '0.0.1',
+ install : true,
+ )
+
diff --git a/libcgif.spec b/libcgif.spec
index 13401c4..4410fff 100644
--- a/libcgif.spec
+++ b/libcgif.spec
@@ -24,6 +24,9 @@ License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+# Fix version in pkgconfig file
+Patch0: %{name}-pc.patch
+
BuildRequires: gcc
BuildRequires: meson
@@ -62,6 +65,7 @@ for %{libname}.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
%build
@@ -72,10 +76,6 @@ for %{libname}.
%install
%meson_install
-# https://github.com/dloebl/cgif/issues/24
-grep ^Version %{buildroot}%{_libdir}/pkgconfig/%{gh_project}.pc
-sed -e 's/undefined/%{version}/' -i %{buildroot}%{_libdir}/pkgconfig/%{gh_project}.pc
-
%check
%meson_test
@@ -96,3 +96,6 @@ sed -e 's/undefined/%{version}/' -i %{buildroot}%{_libdir}/pkgconfig/%{gh_projec
%changelog
* Mon Nov 8 2021 Remi Collet <remi@remirepo.net> - 0.0.1-1
- initial package
+- add patch to fix missing version in pc file
+ reported as https://github.com/dloebl/cgif/issues/24
+ from https://github.com/dloebl/cgif/pull/26