summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--LibRaw-0.6.0-pkgconfig.patch42
-rw-r--r--LibRaw.spec224
2 files changed, 266 insertions, 0 deletions
diff --git a/LibRaw-0.6.0-pkgconfig.patch b/LibRaw-0.6.0-pkgconfig.patch
new file mode 100644
index 0000000..7cabd6b
--- /dev/null
+++ b/LibRaw-0.6.0-pkgconfig.patch
@@ -0,0 +1,42 @@
+--- libraw.pc.in~ 2014-01-17 07:38:31.000000000 -0600
++++ libraw.pc.in 2014-02-20 14:18:20.559279964 -0600
+@@ -7,5 +7,6 @@
+ Description: Raw image decoder library (non-thread-safe)
+ Requires: @PACKAGE_REQUIRES@
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -lraw -lstdc++@PC_OPENMP@
++Libs: -L${libdir} -lraw@PC_OPENMP@
++Libs.private: -lstdc++
+ Cflags: -I${includedir}/libraw
+--- libraw_r.pc.in~ 2014-01-17 07:38:31.000000000 -0600
++++ libraw_r.pc.in 2014-02-20 14:20:35.740276947 -0600
+@@ -7,5 +7,6 @@
+ Description: Raw image decoder library (thread-safe)
+ Requires: @PACKAGE_REQUIRES@
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -lraw_r -lstdc++@PC_OPENMP@
++Libs: -L${libdir} -lraw_r@PC_OPENMP@
++Libs.private: -lstdc++
+ Cflags: -I${includedir}/libraw
+--- libraw_r.pc.in~ 2014-02-20 14:22:36.000000000 -0600
++++ libraw_r.pc.in 2014-02-20 14:27:24.454267828 -0600
+@@ -5,7 +5,7 @@
+
+ Name: libraw
+ Description: Raw image decoder library (thread-safe)
+-Requires: @PACKAGE_REQUIRES@
++Requires.private: @PACKAGE_REQUIRES@
+ Version: @PACKAGE_VERSION@
+ Libs: -L${libdir} -lraw_r@PC_OPENMP@
+ Libs.private: -lstdc++
+--- libraw.pc.in~ 2014-02-20 14:22:36.000000000 -0600
++++ libraw.pc.in 2014-02-20 14:27:18.368267964 -0600
+@@ -5,7 +5,7 @@
+
+ Name: libraw
+ Description: Raw image decoder library (non-thread-safe)
+-Requires: @PACKAGE_REQUIRES@
++Requires.private: @PACKAGE_REQUIRES@
+ Version: @PACKAGE_VERSION@
+ Libs: -L${libdir} -lraw@PC_OPENMP@
+ Libs.private: -lstdc++
diff --git a/LibRaw.spec b/LibRaw.spec
new file mode 100644
index 0000000..ea3673b
--- /dev/null
+++ b/LibRaw.spec
@@ -0,0 +1,224 @@
+Summary: Library for reading RAW files obtained from digital photo cameras
+Name: LibRaw
+Version: 0.19.2
+Release: 1%{?dist}
+License: BSD and (CDDL or LGPLv2)
+URL: http://www.libraw.org
+
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig(lcms2)
+BuildRequires: pkgconfig(jasper)
+BuildRequires: pkgconfig(libjpeg)
+BuildRequires: autoconf automake libtool
+
+Source0: http://www.libraw.org/data/%{name}-%{version}.tar.gz
+Patch0: LibRaw-0.6.0-pkgconfig.patch
+Provides: bundled(dcraw) = 9.25
+
+%description
+LibRaw is a library for reading RAW files obtained from digital photo
+cameras (CRW/CR2, NEF, RAF, DNG, and others).
+
+LibRaw is based on the source codes of the dcraw utility, where part of
+drawbacks have already been eliminated and part will be fixed in future.
+
+%package devel
+Summary: LibRaw development libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+LibRaw development libraries.
+
+This package contains libraries that applications can use to build
+against LibRaw.
+
+%package static
+Summary: LibRaw static development libraries
+Requires: %{name}-devel%{?_isa} = %{version}-%{release}
+
+%description static
+LibRaw static development libraries.
+
+%if 0%{?rhel} != 7
+%package samples
+Summary: LibRaw sample programs
+Requires: %{name} = %{version}-%{release}
+
+%description samples
+LibRaw sample programs
+%endif
+
+%prep
+%setup -q
+
+%patch0 -p0 -b .pkgconfig
+
+%build
+autoreconf -if
+%configure \
+%if 0%{?rhel} == 7
+ --enable-examples=no \
+%else
+ --enable-examples=yes \
+%endif
+ --enable-jasper \
+ --enable-jpeg \
+ --enable-lcms \
+ --enable-openmp
+
+# https://fedoraproject.org/wiki/Packaging:Guidelines#Beware_of_Rpath
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+
+%make_build
+
+%install
+cp -pr doc manual
+chmod 644 LICENSE.CDDL LICENSE.LGPL COPYRIGHT Changelog.txt
+chmod 644 manual/*.html
+
+# The Libraries
+%make_install
+
+rm -rfv samples/.deps
+rm -fv samples/.dirstamp
+rm -fv samples/*.o
+
+rm -fv %{buildroot}%{_libdir}/lib*.la
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%doc Changelog.txt
+%license LICENSE.CDDL LICENSE.LGPL COPYRIGHT
+%{_libdir}/libraw.so.19*
+%{_libdir}/libraw_r.so.19*
+
+%files static
+%{_libdir}/libraw.a
+%{_libdir}/libraw_r.a
+
+%files devel
+%doc manual
+%doc samples
+%{_includedir}/libraw/
+%{_libdir}/libraw.so
+%{_libdir}/libraw_r.so
+%{_libdir}/pkgconfig/libraw.pc
+%{_libdir}/pkgconfig/libraw_r.pc
+%exclude %{_docdir}/libraw/*
+
+%if 0%{?rhel} != 7
+%files samples
+%{_bindir}/*
+%endif
+
+
+%changelog
+* Wed Jan 2 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.19.2-1
+- Update to 0.19.2
+- Resolves: #1543597
+
+* Wed Jan 2 2019 Debarshi Ray <rishi@fedoraproject.org> - 0.19.1-2
+- Remove the samples subpackage from RHEL 7
+- Resolves: #1543597
+
+* Mon Dec 17 2018 Debarshi Ray <rishi@fedoraproject.org> - 0.19.1-1
+- Update to 0.19.1
+- Resolves: #1543597
+
+* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 0.14.8-5.20120830git98d925
+- Mass rebuild 2014-01-24
+
+* Wed Jan 8 2014 Debarshi Ray <rishi@fedoraproject.org> - 0.14.8-4.20120830git98d925
+- Fix CVE-2013-1438 and CVE-2013-1439
+- Resolves: #1002718
+
+* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.14.8-3
+- Mass rebuild 2013-12-27
+
+* Wed May 29 2013 Jon Ciesla <limburgher@gmail.com> - 0.14.8-2
+- Patch for double free, CVE-2013-2126, BZ 968387.
+
+* Wed May 29 2013 Jon Ciesla <limburgher@gmail.com> - 0.14.8-1
+- Latest upstream, fixes gcc 4.8 issues.
+
+* Thu Apr 11 2013 Jon Ciesla <limburgher@gmail.com> - 0.14.7-4
+- Revert prior patch.
+
+* Thu Apr 11 2013 Jon Ciesla <limburgher@gmail.com> - 0.14.7-3
+- Patch for segfault, BZ 948628.
+
+* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.7-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Mon Nov 26 2012 Jon Ciesla <limburgher@gmail.com> - 0.14.7-1
+- New upstream 0.14.7
+
+* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.6-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Sat Jun 2 2012 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> - 0.14.6-2
+- Use lcms2.
+
+* Sat Jun 2 2012 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> - 0.14.6-1
+- New upstream 0.14.6
+
+* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.3-4
+- Rebuilt for c++ ABI breakage
+
+* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.3-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Fri Dec 9 2011 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> - 0.14.3-2
+- Add demosaic packs (bz #760638)
+- Change license to GPLv3+ due to above change
+
+* Wed Nov 16 2011 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> - 0.14.3-1
+- Rebase to upstream 0.14.3
+
+* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.3-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sun Dec 12 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.11.3-2
+- Of course, you need to upload the new sources.
+
+* Sun Dec 12 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.11.3-1
+- upstream 0.11.3
+
+* Sat Nov 13 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-9
+- Build position independent object code
+
+* Thu Jul 08 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-8
+- Remove LibRaw license since we're not distributing LibRaw under its terms
+
+* Wed Jul 07 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-7
+- Buildroot is unnecessary
+- Corrected license to LGPLv2 or CDDL
+
+* Sun Jul 04 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-6
+- Do not impose -O4 and -w in build options
+- Change package group to Development/Libraries
+- Corrected license to LGPLv2
+- setup macro no longer needs the name and version arguments
+- Rename patches to include name and version
+
+* Wed Jun 30 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-5
+- Use optflags for build
+- Install the documentation in a cleaner way
+
+* Tue Jun 29 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-4
+- Use upstream package name (libRaw) instead of libraw
+
+* Tue Jun 29 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-3
+- Remove the clean section since it is not needed in F-13 and later
+- Correct installation of docs into defaultdocdir instead of docdir
+
+* Thu Jun 10 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-2
+- Disable lcms and openmp support by default so that we're in line with
+ upstream default
+
+* Fri Jun 04 2010 Siddhesh Poyarekar <siddhesh.poyarekar@gmail.com> 0.9.1-1
+- New package
+