summaryrefslogtreecommitdiffstats
path: root/icu-last.spec
diff options
context:
space:
mode:
Diffstat (limited to 'icu-last.spec')
-rw-r--r--icu-last.spec58
1 files changed, 38 insertions, 20 deletions
diff --git a/icu-last.spec b/icu-last.spec
index 752f6d3..f2a2174 100644
--- a/icu-last.spec
+++ b/icu-last.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for icu65
+# remirepo spec file for icu73
# renamed for parallel installation, from:
#
# Fedora spec file for icu
@@ -10,14 +10,16 @@
#
%global srcname icu
-%global soname 69
-%global subver 1
+%global soname 73
+%global subver 2
+
+%bcond_without tests
# Set to 0 when upgrading to a new ICU release that contains up-to-date timezone data.
# (or update the timezone data update..).
-%global use_tzdata_update 1
+%global use_tzdata_update 0
# Adjust to version major; used in tzdata update.
-%global icu_major 69
+%global icu_major 73
%if 0%{?fedora} == 34 || 0%{?rhel} == 9
# rhbz#2003359 crash in umtx_initImplPreInit() from unorm_normalize()
@@ -26,17 +28,17 @@
Name: icu%{soname}
Version: %{soname}.%{subver}
-Release: 4%{?dist}
+Release: 1%{?dist}
Summary: International Components for Unicode
-License: MIT and UCD and Public Domain
+License: Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain
URL: http://site.icu-project.org/
Source0: https://github.com/unicode-org/icu/releases/download/release-%{soname}-%{subver}/icu4c-%{soname}_%{subver}-src.tgz
%if 0%{?use_tzdata_update}
-Source1: https://github.com/unicode-org/icu/releases/download/release-69-1/icu4c-69_1-data.zip
-Source2: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022a/44/metaZones.txt
-Source3: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022a/44/timezoneTypes.txt
-Source4: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022a/44/windowsZones.txt
-Source5: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022a/44/zoneinfo64.txt
+Source1: https://github.com/unicode-org/icu/releases/download/release-%{soname}-%{subver}/icu4c-%{soname}_%{subver}-data.zip
+Source2: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/metaZones.txt
+Source3: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/timezoneTypes.txt
+Source4: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/windowsZones.txt
+Source5: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/icunew/2022b/44/zoneinfo64.txt
%endif
Source10: icu-config.sh
@@ -60,8 +62,6 @@ Provides: %{srcname}%{?_isa} = %{version}-%{release}
Patch4: gennorm2-man.patch
Patch5: icuinfo-man.patch
-Patch10: timezone-update.patch
-Patch11: timezone-update-2022a.patch
%description
Tools and utilities for developing with icu.
@@ -112,12 +112,10 @@ Provides: lib%{srcname}-doc = %{version}-%{release}
%prep
%setup -q -n %{srcname}
-%patch4 -p1 -b .gennorm2-man.patch
-%patch5 -p1 -b .icuinfo-man.patch
-%patch10 -p1 -b .up1
-%patch11 -p1 -b .up2
+%patch -P4 -p1 -b .gennorm2-man.patch
+%patch -P5 -p1 -b .icuinfo-man.patch
-%if 0%{?fedora} == 34 || 0%{?rhel} == 9
+%if 1
sed -e '/SELFCHECK=1/d' -i source/Makefile.in
%endif
@@ -179,9 +177,14 @@ chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
)
install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/icu-config
+%if %{with tests}
%check
%{?dtsenable}
+# ignore test
+sed -e '/TestHebrewCalendarInTemporalLeapYear/s:TESTCASE_AUTO://TESTCASE_AUTO:' \
+ -i source/test/intltest/caltest.cpp
+
# test to ensure that -j(X>1) didn't "break" man pages. b.f.u #2357
if grep -q @VERSION@ source/tools/*/*.8 source/tools/*/*.1 source/config/*.1; then
exit 1
@@ -191,6 +194,7 @@ make %{?_smp_mflags} -C source check
# log available codes
pushd source
LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
+%endif
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
@@ -209,16 +213,18 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
%{_bindir}/gencnval
%{_bindir}/gendict
%{_bindir}/genrb
+%{_bindir}/icuexportdata
%{_bindir}/makeconv
%{_bindir}/pkgdata
%{_bindir}/uconv
%{_sbindir}/*
%{_mandir}/man1/derb.1*
+%{_mandir}/man1/genbrk.1*
%{_mandir}/man1/gencfu.1*
%{_mandir}/man1/gencnval.1*
%{_mandir}/man1/gendict.1*
%{_mandir}/man1/genrb.1*
-%{_mandir}/man1/genbrk.1*
+%{_mandir}/man1/icuexportdata.1*
%{_mandir}/man1/makeconv.1*
%{_mandir}/man1/pkgdata.1*
%{_mandir}/man1/uconv.1*
@@ -253,6 +259,18 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
%changelog
+* Mon Oct 30 2023 Remi Collet <remi@remirepo.net> - 73.2-1
+- update to 73.2 (from F39)
+
+* Fri Apr 14 2023 Remi Collet <remi@remirepo.net> - 72.1-1
+- update to 72.1 (from F38)
+
+* Fri Oct 21 2022 Remi Collet <remi@remirepo.net> - 71.1-2
+- Update timezone data to 2022b
+
+* Tue Aug 16 2022 Remi Collet <remi@remirepo.net> - 71.1-1
+- update to 71.1 (from F37)
+
* Tue Jul 26 2022 Remi Collet <remi@remirepo.net> - 69.1-4
- Update timezone data to 2022a