summaryrefslogtreecommitdiffstats
path: root/pkgconfig.patch
diff options
context:
space:
mode:
Diffstat (limited to 'pkgconfig.patch')
-rw-r--r--pkgconfig.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/pkgconfig.patch b/pkgconfig.patch
new file mode 100644
index 0000000..f4500bd
--- /dev/null
+++ b/pkgconfig.patch
@@ -0,0 +1,58 @@
+From 7248409b5b56c825fe3c0a50c4c7e304e8551b40 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 1 Mar 2022 09:47:38 +0100
+Subject: [PATCH] fix pkgconfig installation
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f6313ab..51bcc6e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -107,6 +107,6 @@ configure_file(
+ @ONLY
+ )
+ install(
+- FILES ${CMAKR_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc
+- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/pkgconfig
++ FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+ )
+From 2df75f0b666761a650f7afb749f2dc72e8afb5a2 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 1 Mar 2022 14:59:44 +0100
+Subject: [PATCH 3/3] Clean pkgconfig
+
+---
+ CMakeLists.txt | 4 +---
+ hdr_histogram.pc.in | 2 +-
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 51bcc6e..4a09589 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -95,10 +95,8 @@ set(CPACK_GENERATOR "TGZ")
+ include(CPack)
+
+ if(${ZLIB_FOUND})
+- set(PC_LIBS_PRIVATE_ZLIB "-lz")
+- set(PC_REQUIRES_PRIVATE_ZLIB "zlib >= 1.2.11")
++ set(PC_REQUIRES_PRIVATE_ZLIB "zlib")
+ else()
+- set(PC_LIBS_PRIVATE_ZLIB "")
+ set(PC_REQUIRES_PRIVATE_ZLIB "")
+ endif()
+ configure_file(
+diff --git a/hdr_histogram.pc.in b/hdr_histogram.pc.in
+index a88e5e9..8494dc3 100644
+--- a/hdr_histogram.pc.in
++++ b/hdr_histogram.pc.in
+@@ -9,4 +9,4 @@ Version: @PROJECT_VERSION@
+ Requires.private: @PC_REQUIRES_PRIVATE_ZLIB@
+ Cflags: -I${includedir}
+ Libs: -L${libdir} -l@PROJECT_NAME@
+-Libs.private: -pthread -lm -lrt @PC_LIBS_PRIVATE_ZLIB@ -L${libdir}
++Libs.private: -pthread -lm -lrt -L${libdir}