summaryrefslogtreecommitdiffstats
path: root/hdrhistogram-fpic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'hdrhistogram-fpic.patch')
-rw-r--r--hdrhistogram-fpic.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/hdrhistogram-fpic.patch b/hdrhistogram-fpic.patch
index 53546b0..81c2e45 100644
--- a/hdrhistogram-fpic.patch
+++ b/hdrhistogram-fpic.patch
@@ -1,10 +1,11 @@
---- ./CMakeLists.txt.opts 2016-04-06 11:28:38.677132787 +0200
-+++ ./CMakeLists.txt 2016-04-06 11:29:03.131245198 +0200
-@@ -24,9 +24,7 @@
+diff -up ./CMakeLists.txt.fpic ./CMakeLists.txt
+--- ./CMakeLists.txt.fpic 2019-01-20 08:57:28.000000000 +0100
++++ ./CMakeLists.txt 2019-01-21 11:44:06.556633427 +0100
+@@ -24,9 +24,7 @@ set(HDR_SOVERSION ${HDR_SOVERSION_CURREN
ENABLE_TESTING()
if(UNIX)
-- set(CMAKE_C_FLAGS "-Wall -Wno-unknown-pragmas -Wextra -Wshadow -Winit-self -Wmissing-prototypes -D_GNU_SOURCE")
+- set(CMAKE_C_FLAGS "-Wall -Wno-unknown-pragmas -Wextra -Wshadow -Winit-self -Wmissing-prototypes -Wpedantic -D_GNU_SOURCE -std=gnu89")
- set(CMAKE_C_FLAGS_DEBUG "-O0 -g")
- set(CMAKE_C_FLAGS_RELEASE "-O3 -g")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC -D_GNU_SOURCE")