summaryrefslogtreecommitdiffstats
path: root/hdrhistogram.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-15 11:09:37 +0200
committerRemi Collet <remi@remirepo.net>2020-06-15 11:09:37 +0200
commit6b4d47f4019f87be37418df1856c0ede12ec0c8e (patch)
tree11017177d80ae3f655dbb7bff11d367f3872e628 /hdrhistogram.spec
parentee1530bb98042f82b366570422129b56fa4f0098 (diff)
update to 0.10.0
soname bump to 6 add option to not install static libraries from https://github.com/HdrHistogram/HdrHistogram_c/pull/84 add hdr_histogram_perf command
Diffstat (limited to 'hdrhistogram.spec')
-rw-r--r--hdrhistogram.spec42
1 files changed, 33 insertions, 9 deletions
diff --git a/hdrhistogram.spec b/hdrhistogram.spec
index 6c25771..881011e 100644
--- a/hdrhistogram.spec
+++ b/hdrhistogram.spec
@@ -7,25 +7,32 @@
# Please, preserve the changelog entries
#
-%global gh_commit 933c5dc1f347358450c4cd678132dd93e6ac2134
+%global gh_commit f400fa0de945d458dc83201bf5a369db5220899e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner HdrHistogram
%global gh_project HdrHistogram_c
%global libname libhdr_histogram
-%global soname 5
+%global soname 6
Name: hdrhistogram
Summary: A High Dynamic Range (HDR) Histogram
-Version: 0.9.13
+Version: 0.10.0
Release: 1%{?dist}
License: CC0 or BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Patch0: %{gh_project}-static.patch
+
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+BuildRequires: cmake3 >= 3.5
+BuildRequires: devtoolset-6-toolchain
+%else
+BuildRequires: cmake >= 3.5
BuildRequires: gcc
BuildRequires: gcc-c++
-BuildRequires: cmake > 2.8
+%endif
BuildRequires: zlib-devel
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@@ -62,24 +69,32 @@ This package contains the %{libname} library.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr84
mkdir docs
cp -pr examples docs/examples
-grep CMAKE_C_FLAGS CMakeLists.txt
-
%build
-export CFLAGS="%{optflags} -Wno-unknown-pragmas -std=gnu99"
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+source /opt/rh/devtoolset-6/enable
-%cmake .
+%cmake3 \
+%else
+%cmake \
+%endif
+ -DHDR_HISTOGRAM_INSTALL_STATIC=OFF \
+ .
make %{_smp_mflags}
%install
+%if 0%{?rhel} == 6 || 0%{?rhel} == 7
+source /opt/rh/devtoolset-6/enable
+%endif
+
make install DESTDIR="%{buildroot}"
-rm %{buildroot}/%{_libdir}/%{libname}_static.a
rm %{buildroot}/%{_bindir}/*test
@@ -98,6 +113,7 @@ make test
%doc *.md
%{_bindir}/hiccup
%{_bindir}/hdr_decoder
+%{_bindir}/hdr_histogram_perf
%files libs
%{!?_licensedir:%global license %%doc}
@@ -109,10 +125,18 @@ make test
%doc *.md
%doc docs/examples
%{_libdir}/%{libname}.so
+%{_libdir}/cmake/hdr_histogram
%{_includedir}/hdr
%changelog
+* Mon Jun 15 2020 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+- soname bump to 6
+- add option to not install static libraries from
+ https://github.com/HdrHistogram/HdrHistogram_c/pull/84
+- add hdr_histogram_perf command
+
* Tue Feb 18 2020 Remi Collet <remi@remirepo.net> - 0.9.13-1
- update to 0.9.13
- soname bump to 5