summaryrefslogtreecommitdiffstats
path: root/hdrhistogram.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-06 11:55:13 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-06 11:55:13 +0200
commit1d512bd8742a640a52c13aaa987a18b87bbada32 (patch)
tree57456f21dc53823d1d33970bd4fb7271b5520291 /hdrhistogram.spec
parent7be7f764646e21313696b90de2ee461420a11ad8 (diff)
hdrhistogram: 0.9.3
Diffstat (limited to 'hdrhistogram.spec')
-rw-r--r--hdrhistogram.spec23
1 files changed, 14 insertions, 9 deletions
diff --git a/hdrhistogram.spec b/hdrhistogram.spec
index dde060a..3963e08 100644
--- a/hdrhistogram.spec
+++ b/hdrhistogram.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit eb371a12b9d42b9a9a8c2497841d5fa0d44f6ca4
+%global gh_commit 581014321c66a5607fa0911e60815490c2f64650
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner HdrHistogram
%global gh_project HdrHistogram_c
@@ -16,7 +16,7 @@
Name: hdrhistogram
Summary: A High Dynamic Range (HDR) Histogram
-Version: 0.9.1
+Version: 0.9.3
Release: 1%{?dist}
License: CC0 or BSD
Group: System Environment/Libraries
@@ -24,10 +24,11 @@ Group: System Environment/Libraries
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# See https://github.com/HdrHistogram/HdrHistogram_c/pull/28
-# honours LIB_SUFFIX option
-# set soname version
-Patch0: %{name}-pr28.patch
+# build with fPIC
+Patch0: %{name}-fpic.patch
+# See https://github.com/HdrHistogram/HdrHistogram_c/issues/31
+# fix soname version
+Patch1: %{name}-sover.patch
BuildRequires: cmake > 2.8
BuildRequires: zlib-devel
@@ -71,9 +72,10 @@ This package contains the %{libname} library.
mkdir docs
cp -pr examples docs/examples
-%patch0 -p1 -b .pr28
+%patch0 -p1 -b .fpic
+%patch1 -p1 -b .pr28
-sed -e '/CMAKE_C_FLAGS/d' -i CMakeLists.txt
+grep CMAKE_C_FLAGS CMakeLists.txt
%build
@@ -91,6 +93,9 @@ make %{_smp_mflags}
%install
make install DESTDIR="%{buildroot}"
+# https://github.com/HdrHistogram/HdrHistogram_c/issues/32
+install -p src/hdr_thread.h %{buildroot}%{_includedir}/hdr/hdr_thread.h
+
rm %{buildroot}/%{_libdir}/%{libname}_static.a
rm %{buildroot}/%{_bindir}/*test
@@ -124,4 +129,4 @@ make test
%changelog
* Fri Jan 1 2016 Remi Collet <remi@fedoraproject.org> - 0.9.1-1
-- initial package \ No newline at end of file
+- initial package