summaryrefslogtreecommitdiffstats
path: root/HdrHistogram_c-static.patch
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-15 11:09:37 +0200
committerRemi Collet <remi@remirepo.net>2020-06-15 11:09:37 +0200
commit6b4d47f4019f87be37418df1856c0ede12ec0c8e (patch)
tree11017177d80ae3f655dbb7bff11d367f3872e628 /HdrHistogram_c-static.patch
parentee1530bb98042f82b366570422129b56fa4f0098 (diff)
update to 0.10.0
soname bump to 6 add option to not install static libraries from https://github.com/HdrHistogram/HdrHistogram_c/pull/84 add hdr_histogram_perf command
Diffstat (limited to 'HdrHistogram_c-static.patch')
-rw-r--r--HdrHistogram_c-static.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/HdrHistogram_c-static.patch b/HdrHistogram_c-static.patch
new file mode 100644
index 0000000..de85b37
--- /dev/null
+++ b/HdrHistogram_c-static.patch
@@ -0,0 +1,56 @@
+From d74a6abee509010a17c4a2c18e9d29acd3bad5d4 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 15 Jun 2020 10:50:12 +0200
+Subject: [PATCH] add options to be able to not install libraries
+
+---
+ src/CMakeLists.txt | 18 +++++++++++-------
+ 1 file changed, 11 insertions(+), 7 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index a30f8fc..60be048 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -28,7 +28,7 @@ set(HDR_HISTOGRAM_PUBLIC_HEADERS
+ hdr_time.h
+ hdr_writer_reader_phaser.h)
+
+-function(hdr_histogram_add_library NAME LIBRARY_TYPE)
++function(hdr_histogram_add_library NAME LIBRARY_TYPE DO_INSTALL)
+ add_library(${NAME} ${LIBRARY_TYPE}
+ ${HDR_HISTOGRAM_SOURCES}
+ ${HDR_HISTOGRAM_PRIVATE_HEADERS}
+@@ -44,23 +44,27 @@ function(hdr_histogram_add_library NAME LIBRARY_TYPE)
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>)
+- install(
+- TARGETS ${NAME}
+- EXPORT ${PROJECT_NAME}-targets
+- DESTINATION ${CMAKE_INSTALL_LIBDIR})
++ if(DO_INSTALL)
++ install(
++ TARGETS ${NAME}
++ EXPORT ${PROJECT_NAME}-targets
++ DESTINATION ${CMAKE_INSTALL_LIBDIR})
++ endif()
+ endfunction()
+
+ option(HDR_HISTOGRAM_BUILD_SHARED "Build shared library" ON)
++option(HDR_HISTOGRAM_BUILD_SHARED "Install shared library" ON)
+ if(HDR_HISTOGRAM_BUILD_SHARED)
+- hdr_histogram_add_library(hdr_histogram SHARED)
++ hdr_histogram_add_library(hdr_histogram SHARED ${HDR_HISTOGRAM_BUILD_SHARED})
+ set_target_properties(hdr_histogram PROPERTIES
+ VERSION ${HDR_VERSION}
+ SOVERSION ${HDR_SOVERSION})
+ endif()
+
+ option(HDR_HISTOGRAM_BUILD_STATIC "Build static library" ON)
++option(HDR_HISTOGRAM_INSTALL_STATIC "Install static library" ON)
+ if(HDR_HISTOGRAM_BUILD_STATIC)
+- hdr_histogram_add_library(hdr_histogram_static STATIC)
++ hdr_histogram_add_library(hdr_histogram_static STATIC ${HDR_HISTOGRAM_INSTALL_STATIC})
+ endif()
+
+ install(