summaryrefslogtreecommitdiffstats
path: root/HdrHistogram_c-static.patch
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-01 15:13:55 +0100
committerRemi Collet <remi@php.net>2022-03-01 15:13:55 +0100
commit6102f62b25a9642552d572a8e2e8c2baf3b0cc71 (patch)
treebb4e7770e5faf0e76b0fd84a523beae3d5df6886 /HdrHistogram_c-static.patch
parent1af4da8c4ecff2982aef984c23a75d77cf329e0e (diff)
better fix for pkgconfig file
Diffstat (limited to 'HdrHistogram_c-static.patch')
-rw-r--r--HdrHistogram_c-static.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/HdrHistogram_c-static.patch b/HdrHistogram_c-static.patch
deleted file mode 100644
index de85b37..0000000
--- a/HdrHistogram_c-static.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From d74a6abee509010a17c4a2c18e9d29acd3bad5d4 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 15 Jun 2020 10:50:12 +0200
-Subject: [PATCH] add options to be able to not install libraries
-
----
- src/CMakeLists.txt | 18 +++++++++++-------
- 1 file changed, 11 insertions(+), 7 deletions(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index a30f8fc..60be048 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -28,7 +28,7 @@ set(HDR_HISTOGRAM_PUBLIC_HEADERS
- hdr_time.h
- hdr_writer_reader_phaser.h)
-
--function(hdr_histogram_add_library NAME LIBRARY_TYPE)
-+function(hdr_histogram_add_library NAME LIBRARY_TYPE DO_INSTALL)
- add_library(${NAME} ${LIBRARY_TYPE}
- ${HDR_HISTOGRAM_SOURCES}
- ${HDR_HISTOGRAM_PRIVATE_HEADERS}
-@@ -44,23 +44,27 @@ function(hdr_histogram_add_library NAME LIBRARY_TYPE)
- PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
- $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>)
-- install(
-- TARGETS ${NAME}
-- EXPORT ${PROJECT_NAME}-targets
-- DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+ if(DO_INSTALL)
-+ install(
-+ TARGETS ${NAME}
-+ EXPORT ${PROJECT_NAME}-targets
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+ endif()
- endfunction()
-
- option(HDR_HISTOGRAM_BUILD_SHARED "Build shared library" ON)
-+option(HDR_HISTOGRAM_BUILD_SHARED "Install shared library" ON)
- if(HDR_HISTOGRAM_BUILD_SHARED)
-- hdr_histogram_add_library(hdr_histogram SHARED)
-+ hdr_histogram_add_library(hdr_histogram SHARED ${HDR_HISTOGRAM_BUILD_SHARED})
- set_target_properties(hdr_histogram PROPERTIES
- VERSION ${HDR_VERSION}
- SOVERSION ${HDR_SOVERSION})
- endif()
-
- option(HDR_HISTOGRAM_BUILD_STATIC "Build static library" ON)
-+option(HDR_HISTOGRAM_INSTALL_STATIC "Install static library" ON)
- if(HDR_HISTOGRAM_BUILD_STATIC)
-- hdr_histogram_add_library(hdr_histogram_static STATIC)
-+ hdr_histogram_add_library(hdr_histogram_static STATIC ${HDR_HISTOGRAM_INSTALL_STATIC})
- endif()
-
- install(