summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gd-upstream.patch50
-rw-r--r--gd.spec8
2 files changed, 7 insertions, 51 deletions
diff --git a/gd-upstream.patch b/gd-upstream.patch
deleted file mode 100644
index 8aee1a0..0000000
--- a/gd-upstream.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From c9b601a658a79e6ea2aad29fbf60ca6e24ccef1e Mon Sep 17 00:00:00 2001
-From: "Christoph M. Becker" <cmbecker69@gmx.de>
-Date: Wed, 18 Jan 2017 13:59:02 +0100
-Subject: [PATCH] Fix build issue regarding INT_MAX
-
-For portability gd_gd2.c needs to include <limits.h>.
----
- src/gd_gd2.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/gd_gd2.c b/src/gd_gd2.c
-index c2904ca..049c4c5 100644
---- a/src/gd_gd2.c
-+++ b/src/gd_gd2.c
-@@ -74,6 +74,7 @@
-
- /* 2.0.29: no more errno.h, makes windows happy */
- #include <math.h>
-+#include <limits.h>
- #include <string.h>
- #include "gd.h"
- #include "gd_errors.h"
-
-
-From 55ac28a293eaa8c531870c8bb8ecc04b333975f4 Mon Sep 17 00:00:00 2001
-From: "Christoph M. Becker" <cmbecker69@gmx.de>
-Date: Thu, 19 Jan 2017 01:02:58 +0100
-Subject: [PATCH] Fix #357: 2.2.4: Segfault in test suite.
-
-We make sure to never pass a negative `int` as argument to a `size_t`
-parameter.
----
- src/gd_io_dp.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/gd_io_dp.c b/src/gd_io_dp.c
-index eda2eeb..cb38794 100644
---- a/src/gd_io_dp.c
-+++ b/src/gd_io_dp.c
-@@ -292,6 +292,10 @@ static int dynamicGetbuf(gdIOCtxPtr ctx, void *buf, int len)
- rlen = dp->realSize - dp->pos;
- }
-
-+ if (rlen < 0) {
-+ return 0;
-+ }
-+
- memcpy(buf, (void *) ((char *)dp->data + dp->pos), rlen);
- dp->pos += rlen;
-
diff --git a/gd.spec b/gd.spec
index a5f6590..1db9af4 100644
--- a/gd.spec
+++ b/gd.spec
@@ -28,7 +28,7 @@ Name: gd
Name: gd-last
%endif
Version: 2.2.5
-Release: 5%{?prever}%{?short}%{?dist}
+Release: 6%{?prever}%{?short}%{?dist}
Group: System Environment/Libraries
License: MIT
URL: http://libgd.github.io/
@@ -67,6 +67,9 @@ BuildRequires: perl
BuildRequires: perl-generators
# for fontconfig/basic test
BuildRequires: liberation-sans-fonts
+%if 0%{?fedora} >= 29
+BuildRequires: libimagequant-devel
+%endif
%if "%{name}" != "gd-last"
Obsoletes: gd-last <= %{version}
@@ -226,6 +229,9 @@ grep %{version} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gdlib.pc
%changelog
+* Thu Aug 30 2018 mskalick@redhat.com - 2.2.5-6
+- Use libimagequant library (RHBZ#1468338)
+
* Thu Aug 30 2018 mskalick@redhat.com - 2.2.5-5
- Check return value in gdImageBmpPtr to avoid double free (CVE-2018-1000222)
- Don't mark gdimagegrayscale/basic test as failing