summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gd.spec4
-rw-r--r--getlib.sh42
-rw-r--r--label.heicbin0 -> 1170 bytes
3 files changed, 2 insertions, 44 deletions
diff --git a/gd.spec b/gd.spec
index 6b18e59..957caa4 100644
--- a/gd.spec
+++ b/gd.spec
@@ -56,7 +56,7 @@ Source0: libgd-%{version}-%{commit}.tgz
Source0: https://github.com/libgd/libgd/releases/download/gd-%{version}/libgd-%{version}.tar.xz
%endif
# Missing, temporary workaround, fixed upstream for next version
-Source1: https://raw.githubusercontent.com/libgd/libgd/gd-%{version}/config/getlib.sh
+Source1: https://raw.githubusercontent.com/libgd/libgd/gd-%{version}/tests/heif/label.heic
BuildRequires: freetype-devel
BuildRequires: fontconfig-devel
@@ -165,7 +165,7 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
%prep
%setup -q -n libgd-%{version}%{?prever:-%{prever}}
-install -m 0755 %{SOURCE1} config/
+install -m 0644 %{SOURCE1} tests/heif/
: $(perl config/getver.pl)
diff --git a/getlib.sh b/getlib.sh
deleted file mode 100644
index 4835cf6..0000000
--- a/getlib.sh
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-
-GETVER="${0%/*}/getver.pl"
-GDLIB_MAJOR=$("${GETVER}" MAJOR)
-GDLIB_MINOR=$("${GETVER}" MINOR)
-GDLIB_REVISION=$("${GETVER}" RELEASE)
-
-# Dynamic library version information
-# See http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info
-
-GDLIB_LT_CURRENT=3
-# This is the version where the soname (current above) changes. We use it
-# to reset the revision base back to zero. It's a bit of a pain, but some
-# systems restrict the revision range below to [0..255] (like OS X).
-GDLIB_PREV_MAJOR=2
-GDLIB_PREV_MINOR=2
-# This isn't 100% correct, but it tends to be a close enough approximation
-# for how we manage the codebase. It's rare to do a release that doesn't
-# modify the library since this project is centered around the library.
-GDLIB_LT_REVISION=$(( ((GDLIB_MAJOR - GDLIB_PREV_MAJOR) << 6) | ((GDLIB_MINOR - GDLIB_PREV_MINOR) << 3) | GDLIB_REVISION ))
-GDLIB_LT_AGE=0
-
-# The first three fields we feed into libtool and the OS target determines how
-# they get used. The last two fields we feed into cmake. We use the same rules
-# as Linux SONAME versioning in libtool, but cmake should handle it for us.
-case $1 in
-CURRENT)
- printf '%s' "${GDLIB_LT_CURRENT}"
- ;;
-REVISION)
- printf '%s' "${GDLIB_LT_REVISION}"
- ;;
-AGE)
- printf '%s' "${GDLIB_LT_AGE}"
- ;;
-VERSION)
- printf '%s' "$(( GDLIB_LT_CURRENT - GDLIB_LT_AGE )).${GDLIB_LT_AGE}.${GDLIB_LT_REVISION}"
- ;;
-SONAME)
- printf '%s' "$(( GDLIB_LT_CURRENT - GDLIB_LT_AGE ))"
- ;;
-esac
diff --git a/label.heic b/label.heic
new file mode 100644
index 0000000..12814f7
--- /dev/null
+++ b/label.heic
Binary files differ