summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gd.spec37
-rw-r--r--libgd-bumpsoname.patch12
2 files changed, 44 insertions, 5 deletions
diff --git a/gd.spec b/gd.spec
index d3f5d5c..cde3cc4 100644
--- a/gd.spec
+++ b/gd.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for gd-last
+# remirepo spec file for gd3php
# renamed for parallel installation, from:
#
# Fedora spec file for gd
@@ -12,7 +12,9 @@
#global commit 725ba9de4005144d137d2a7a70f760068fc3d306
#global short %%(c=%%{commit}; echo ${c:0:7})
-%if 0%{?rhel} >= 7 && 0%{?rhel} <= 8
+%bcond_without tests
+
+%if 0%{?rhel} >= 7 && 0%{?rhel} <= 9
%bcond_without bump
%else
%bcond_with bump
@@ -20,14 +22,15 @@
%bcond_without webp
%if 0%{?fedora} >= 35
-# disabled as breaks vertical text
+# disabled as breaks vertical text with freetype >= 2.11
# See https://bugzilla.redhat.com/2022957
+# https://github.com/libgd/libgd/issues/790
%bcond_with raqm
%else
%bcond_without raqm
%endif
-%if 0%{?fedora} >= 33
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
%bcond_without avif
%else
# Not available or too old
@@ -57,7 +60,7 @@ Name: gd3php
Name: gd
%endif
Version: 2.3.3
-Release: 4%{?prever}%{?short}%{?dist}
+Release: 9%{?prever}%{?short}%{?dist}
License: MIT
URL: http://libgd.github.io/
%if 0%{?commit:1}
@@ -112,6 +115,7 @@ BuildRequires: perl(FindBin)
# for fontconfig/basic test
BuildRequires: liberation-sans-fonts
+Obsoletes: gd-last < %{version}-%{release}
%description
The gd graphics library allows your code to quickly draw images
@@ -129,6 +133,7 @@ Summary: Utility programs that use libgd
Conflicts: gd-progs < %{version}
Provides: gd-progs = %{version}-%{release}
%endif
+Obsoletes: gd-last-progs < %{version}-%{release}
%description progs
The gd-progs package includes utility programs supplied with gd, a
@@ -144,8 +149,12 @@ Requires: libjpeg-devel%{?_isa}
Requires: libpng-devel%{?_isa}
Requires: libtiff-devel%{?_isa}
%if %{with webp}
+%if 0%{?rhel} == 7
+Requires: libwebp7-devel%{?_isa}
+%else
Requires: libwebp-devel%{?_isa}
%endif
+%endif
Requires: libX11-devel%{?_isa}
Requires: libXpm-devel%{?_isa}
Requires: zlib-devel%{?_isa}
@@ -166,6 +175,7 @@ Requires: libheif-devel
Conflicts: gd-devel < %{version}
Provides: gd-devel = %{version}-%{release}
%endif
+Obsoletes: gd-last-devel < %{version}-%{release}
%description devel
@@ -250,6 +260,7 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/libgd.la
rm -f $RPM_BUILD_ROOT/%{_libdir}/libgd.a
+%if %{with tests}
%check
XFAIL_TESTS=""
%if 0%{?fedora} <= 28 && 0%{?rhel} <= 7
@@ -267,6 +278,7 @@ make check %{?_smp_mflags}
: Check content of pkgconfig
grep %{version} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gdlib.pc
+%endif
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
@@ -294,6 +306,21 @@ grep %{version} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gdlib.pc
%changelog
+* Thu Nov 17 2022 Remi Collet <remi@remirepo.net> - 2.3.3-9
+- EL-9 rebuild for new libavif
+
+* Tue Jul 19 2022 Remi Collet <remi@remirepo.net> - 2.3.3-8
+- enable avif support in EL-8 and EL-9
+
+* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 2.3.3-7
+- obsolete old gd-last packages
+
+* Wed Jun 22 2022 Remi Collet <remi@remirepo.net> - 2.3.3-6
+- EL-7: devel requires libwebp7-devel (not libwebp-devel)
+
+* Tue Mar 29 2022 Remi Collet <remi@remirepo.net> - 2.3.3-5
+- rename to gd3php on EL-9
+
* Thu Dec 2 2021 Remi Collet <remi@remirepo.net> - 2.3.3-4
- rename to gd3php on EL-7 and EL-8
https://github.com/remicollet/remirepo/issues/194
diff --git a/libgd-bumpsoname.patch b/libgd-bumpsoname.patch
new file mode 100644
index 0000000..dadcc5d
--- /dev/null
+++ b/libgd-bumpsoname.patch
@@ -0,0 +1,12 @@
+diff -up ./config/getlib.sh.old ./config/getlib.sh
+--- ./config/getlib.sh.old 2021-12-02 10:39:08.156110846 +0100
++++ ./config/getlib.sh 2021-12-02 10:39:11.003100629 +0100
+@@ -8,7 +8,7 @@ GDLIB_REVISION=$("${GETVER}" RELEASE)
+ # Dynamic library version information
+ # See http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info
+
+-GDLIB_LT_CURRENT=3
++GDLIB_LT_CURRENT=103
+ # This is the version where the soname (current above) changes. We use it
+ # to reset the revision base back to zero. It's a bit of a pain, but some
+ # systems restrict the revision range below to [0..255] (like OS X).