summaryrefslogtreecommitdiffstats
path: root/diffmark-0.09-remove_rpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'diffmark-0.09-remove_rpath.patch')
-rw-r--r--diffmark-0.09-remove_rpath.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/diffmark-0.09-remove_rpath.patch b/diffmark-0.09-remove_rpath.patch
new file mode 100644
index 0000000..1c7b0bc
--- /dev/null
+++ b/diffmark-0.09-remove_rpath.patch
@@ -0,0 +1,15 @@
+Remove RPATH
+
+Then libtoolize -f && autoreconf to get rid of RPATH in libtool.
+
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index 951a1c5..6f53a59 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -9,5 +9,5 @@ diffmarkinc_HEADERS = compare.hh compareimpl.hh diff.hh lcs.hh lcsimpl.hh link.h
+
+ libdiffmark_la_SOURCES = compare.cc diff.cc link.cc merge.cc namespacecollector.cc nspace.cc target.cc xbuffer.cc xdoc.cc xutil.cc
+
+-libdiffmark_la_LDFLAGS = -rpath $(libdir) -version-info 2:3:1 @DEPS_LIBS@ -lstdc++
++libdiffmark_la_LDFLAGS = -version-info 2:3:1 @DEPS_LIBS@ -lstdc++
+