summaryrefslogtreecommitdiffstats
path: root/0011-curl-7.27.0-2eb8dcf2.patch
diff options
context:
space:
mode:
Diffstat (limited to '0011-curl-7.27.0-2eb8dcf2.patch')
-rw-r--r--0011-curl-7.27.0-2eb8dcf2.patch295
1 files changed, 0 insertions, 295 deletions
diff --git a/0011-curl-7.27.0-2eb8dcf2.patch b/0011-curl-7.27.0-2eb8dcf2.patch
deleted file mode 100644
index f77f104..0000000
--- a/0011-curl-7.27.0-2eb8dcf2.patch
+++ /dev/null
@@ -1,295 +0,0 @@
-From 5ceda5fa61a87015275ab94f99da4f92f49ac802 Mon Sep 17 00:00:00 2001
-From: Kamil Dudka <kdudka@redhat.com>
-Date: Fri, 12 Apr 2013 16:49:32 +0200
-Subject: [PATCH 1/3] test1216: test tailmatching cookie domains
-
-This test is an attempt to repeat the problem YAMADA Yasuharu reported
-at http://curl.haxx.se/mail/lib-2013-04/0108.html
-
-Conflicts:
-
- tests/data/Makefile.am
-
-Signed-off-by: Kamil Dudka <kdudka@redhat.com>
----
- tests/data/Makefile.am | 2 +-
- tests/data/Makefile.in | 2 +-
- tests/data/test1216 | 62 ++++++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 64 insertions(+), 2 deletions(-)
- create mode 100644 tests/data/test1216
-
-diff --git a/tests/data/Makefile.am b/tests/data/Makefile.am
-index 372f127..9321d61 100644
---- a/tests/data/Makefile.am
-+++ b/tests/data/Makefile.am
-@@ -78,7 +78,7 @@ test1118 test1119 test1120 test1121 test1122 test1123 test1124 test1125 \
- test1126 test1127 test1128 test1129 test1130 test1131 \
- test1200 test1201 test1202 test1203 test1204 test1205 test1206 test1207 \
- test1208 test1209 test1210 test1211 \
--test1220 \
-+test1220 test1216 \
- test1300 test1301 test1302 test1303 test1304 test1305 \
- test1306 test1307 test1308 test1309 test1310 test1311 test1312 test1313 \
- test1314 test1315 test1316 test1317 test1318 test1319 test1320 test1321 \
-diff --git a/tests/data/Makefile.in b/tests/data/Makefile.in
-index e0a554a..0c18cb5 100644
---- a/tests/data/Makefile.in
-+++ b/tests/data/Makefile.in
-@@ -343,7 +343,7 @@ test1118 test1119 test1120 test1121 test1122 test1123 test1124 test1125 \
- test1126 test1127 test1128 test1129 test1130 test1131 \
- test1200 test1201 test1202 test1203 test1204 test1205 test1206 test1207 \
- test1208 test1209 test1210 test1211 \
--test1220 \
-+test1220 test1216 \
- test1300 test1301 test1302 test1303 test1304 test1305 \
- test1306 test1307 test1308 test1309 test1310 test1311 test1312 test1313 \
- test1314 test1315 test1316 test1317 test1318 test1319 test1320 test1321 \
-diff --git a/tests/data/test1216 b/tests/data/test1216
-new file mode 100644
-index 0000000..e63fe92
---- /dev/null
-+++ b/tests/data/test1216
-@@ -0,0 +1,62 @@
-+<testcase>
-+<info>
-+<keywords>
-+HTTP
-+HTTP GET
-+HTTP proxy
-+cookies
-+</keywords>
-+</info>
-+
-+# Server-side
-+<reply>
-+<data>
-+HTTP/1.1 200 OK
-+Server: Microsoft-IIS/4.0
-+Date: Tue, 25 Sep 2001 19:37:44 GMT
-+Content-Type: text/html
-+Connection: close
-+Content-Length: 21
-+
-+This server says moo
-+</data>
-+</reply>
-+
-+# Client-side
-+<client>
-+<server>
-+http
-+</server>
-+ <name>
-+HTTP cookie domains tailmatching the host name
-+ </name>
-+ <command>
-+http://example.fake/c/1216 http://bexample.fake/c/1216 -b log/injar1216 -x %HOSTIP:%HTTPPORT
-+</command>
-+<file name="log/injar1216">
-+example.fake FALSE /a FALSE 2139150993 mooo indeed
-+example.fake FALSE /b FALSE 0 moo1 indeed
-+example.fake FALSE /c FALSE 2139150993 moo2 indeed
-+</file>
-+</client>
-+
-+# Verify data after the test has been "shot"
-+<verify>
-+<strip>
-+^User-Agent:.*
-+</strip>
-+<protocol>
-+GET http://example.fake/c/1216 HTTP/1.1
-+Host: example.fake
-+Accept: */*
-+Proxy-Connection: Keep-Alive
-+Cookie: moo2=indeed
-+
-+GET http://bexample.fake/c/1216 HTTP/1.1
-+Host: bexample.fake
-+Accept: */*
-+Proxy-Connection: Keep-Alive
-+
-+</protocol>
-+</verify>
-+</testcase>
---
-1.7.1
-
-
-From 3cf21844356a152df3af92530bb607ef880588af Mon Sep 17 00:00:00 2001
-From: YAMADA Yasuharu <yasuharu.yamada@access-company.com>
-Date: Thu, 11 Apr 2013 00:17:15 +0200
-Subject: [PATCH 2/3] cookie: fix tailmatching to prevent cross-domain leakage
-
-Cookies set for 'example.com' could accidentaly also be sent by libcurl
-to the 'bexample.com' (ie with a prefix to the first domain name).
-
-This is a security vulnerabilty, CVE-2013-1944.
-
-Bug: http://curl.haxx.se/docs/adv_20130412.html
-
-Signed-off-by: Kamil Dudka <kdudka@redhat.com>
----
- lib/cookie.c | 24 +++++++++++++++++++-----
- 1 files changed, 19 insertions(+), 5 deletions(-)
-
-diff --git a/lib/cookie.c b/lib/cookie.c
-index 644b33a..760a931 100644
---- a/lib/cookie.c
-+++ b/lib/cookie.c
-@@ -118,15 +118,29 @@ static void freecookie(struct Cookie *co)
- free(co);
- }
-
--static bool tailmatch(const char *little, const char *bigone)
-+static bool tailmatch(const char *cooke_domain, const char *hostname)
- {
-- size_t littlelen = strlen(little);
-- size_t biglen = strlen(bigone);
-+ size_t cookie_domain_len = strlen(cooke_domain);
-+ size_t hostname_len = strlen(hostname);
-
-- if(littlelen > biglen)
-+ if(hostname_len < cookie_domain_len)
- return FALSE;
-
-- return Curl_raw_equal(little, bigone+biglen-littlelen) ? TRUE : FALSE;
-+ if(!Curl_raw_equal(cooke_domain, hostname+hostname_len-cookie_domain_len))
-+ return FALSE;
-+
-+ /* A lead char of cookie_domain is not '.'.
-+ RFC6265 4.1.2.3. The Domain Attribute says:
-+ For example, if the value of the Domain attribute is
-+ "example.com", the user agent will include the cookie in the Cookie
-+ header when making HTTP requests to example.com, www.example.com, and
-+ www.corp.example.com.
-+ */
-+ if(hostname_len == cookie_domain_len)
-+ return TRUE;
-+ if('.' == *(hostname + hostname_len - cookie_domain_len - 1))
-+ return TRUE;
-+ return FALSE;
- }
-
- /*
---
-1.7.1
-
-
-From cb95277d4732d7e9a50df7cca2ce0aa8dc0aa5b9 Mon Sep 17 00:00:00 2001
-From: Kamil Dudka <kdudka@redhat.com>
-Date: Fri, 12 Apr 2013 16:50:11 +0200
-Subject: [PATCH 3/3] test1218: another cookie tailmatch test
-
-These tests verify commit 3604fde3d3c9b0d, the fix for the "cookie
-domain tailmatch" vulnerability. See
-http://curl.haxx.se/docs/adv_20130412.html
-
-Conflicts:
-
- tests/data/Makefile.am
-
-Signed-off-by: Kamil Dudka <kdudka@redhat.com>
----
- tests/data/Makefile.am | 2 +-
- tests/data/Makefile.in | 2 +-
- tests/data/test1218 | 61 ++++++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 63 insertions(+), 2 deletions(-)
- create mode 100644 tests/data/test1218
-
-diff --git a/tests/data/Makefile.am b/tests/data/Makefile.am
-index 9321d61..c8295c3 100644
---- a/tests/data/Makefile.am
-+++ b/tests/data/Makefile.am
-@@ -78,7 +78,7 @@ test1118 test1119 test1120 test1121 test1122 test1123 test1124 test1125 \
- test1126 test1127 test1128 test1129 test1130 test1131 \
- test1200 test1201 test1202 test1203 test1204 test1205 test1206 test1207 \
- test1208 test1209 test1210 test1211 \
--test1220 test1216 \
-+test1220 test1216 test1218 \
- test1300 test1301 test1302 test1303 test1304 test1305 \
- test1306 test1307 test1308 test1309 test1310 test1311 test1312 test1313 \
- test1314 test1315 test1316 test1317 test1318 test1319 test1320 test1321 \
-diff --git a/tests/data/Makefile.in b/tests/data/Makefile.in
-index 0c18cb5..96678cd 100644
---- a/tests/data/Makefile.in
-+++ b/tests/data/Makefile.in
-@@ -343,7 +343,7 @@ test1118 test1119 test1120 test1121 test1122 test1123 test1124 test1125 \
- test1126 test1127 test1128 test1129 test1130 test1131 \
- test1200 test1201 test1202 test1203 test1204 test1205 test1206 test1207 \
- test1208 test1209 test1210 test1211 \
--test1220 test1216 \
-+test1220 test1216 test1218 \
- test1300 test1301 test1302 test1303 test1304 test1305 \
- test1306 test1307 test1308 test1309 test1310 test1311 test1312 test1313 \
- test1314 test1315 test1316 test1317 test1318 test1319 test1320 test1321 \
-diff --git a/tests/data/test1218 b/tests/data/test1218
-new file mode 100644
-index 0000000..7d86547
---- /dev/null
-+++ b/tests/data/test1218
-@@ -0,0 +1,61 @@
-+<testcase>
-+<info>
-+<keywords>
-+HTTP
-+HTTP GET
-+HTTP proxy
-+cookies
-+</keywords>
-+</info>
-+
-+# This test is very similar to 1216, only that it sets the cookies from the
-+# first site instead of reading from a file
-+<reply>
-+<data>
-+HTTP/1.1 200 OK
-+Date: Tue, 25 Sep 2001 19:37:44 GMT
-+Set-Cookie: domain=.example.fake; bug=fixed;
-+Content-Length: 21
-+
-+This server says moo
-+</data>
-+</reply>
-+
-+# Client-side
-+<client>
-+<server>
-+http
-+</server>
-+ <name>
-+HTTP cookies and domains with same prefix
-+ </name>
-+ <command>
-+http://example.fake/c/1218 http://example.fake/c/1218 http://bexample.fake/c/1218 -b nonexisting -x %HOSTIP:%HTTPPORT
-+</command>
-+</client>
-+
-+# Verify data after the test has been "shot"
-+<verify>
-+<strip>
-+^User-Agent:.*
-+</strip>
-+<protocol>
-+GET http://example.fake/c/1218 HTTP/1.1
-+Host: example.fake
-+Accept: */*
-+Proxy-Connection: Keep-Alive
-+
-+GET http://example.fake/c/1218 HTTP/1.1
-+Host: example.fake
-+Accept: */*
-+Proxy-Connection: Keep-Alive
-+Cookie: bug=fixed
-+
-+GET http://bexample.fake/c/1218 HTTP/1.1
-+Host: bexample.fake
-+Accept: */*
-+Proxy-Connection: Keep-Alive
-+
-+</protocol>
-+</verify>
-+</testcase>
---
-1.7.1
-