summaryrefslogtreecommitdiffstats
path: root/mysql-testing.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-11 11:48:04 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-11 11:48:04 +0100
commitcc426cff465c5e67cc7ae21af2ca6924ed59db20 (patch)
tree88e02fdc8779c3a39e5474c12f4754e9b4708994 /mysql-testing.patch
parentbb5aa75b1d4c9589faf6dd1e1bba74f65a06656b (diff)
compat-mysql51: 5.1.73HEADmaster
Diffstat (limited to 'mysql-testing.patch')
-rw-r--r--mysql-testing.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/mysql-testing.patch b/mysql-testing.patch
new file mode 100644
index 0000000..7438713
--- /dev/null
+++ b/mysql-testing.patch
@@ -0,0 +1,23 @@
+Hack the top-level Makefile to enable the openssl regression tests.
+(Why doesn't this happen automatically given the configure option??)
+
+Also, increase the overall timeout for the regression tests to 12 hours,
+because on a slow or heavily-loaded build machine sometimes the default of
+5 hours isn't enough. (This has been demonstrated to fail in mass-rebuild
+scenarios, which aren't that uncommon for Fedora.) Similarly increase the
+per-testcase timeout to 30 minutes, since the default of 15 hasn't got a
+great deal of headroom either.
+
+
+diff -Naur mysql-5.1.32.orig/Makefile.am mysql-5.1.32/Makefile.am
+--- mysql-5.1.32.orig/Makefile.am 2009-02-13 19:51:56.000000000 -0500
++++ mysql-5.1.32/Makefile.am 2009-03-04 18:12:36.000000000 -0500
+@@ -98,7 +98,7 @@
+
+ test-ns:
+ cd mysql-test ; \
+- @PERL@ ./mysql-test-run.pl $(force) $(mem) --mysqld=--binlog-format=mixed
++ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ssl --mysqld=--binlog-format=mixed --suite-timeout=720 --testcase-timeout=30
+
+ test-binlog-statement:
+ cd mysql-test ; \