summaryrefslogtreecommitdiffstats
path: root/mysql-no-docs.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-11 11:48:04 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-11 11:48:04 +0100
commitcc426cff465c5e67cc7ae21af2ca6924ed59db20 (patch)
tree88e02fdc8779c3a39e5474c12f4754e9b4708994 /mysql-no-docs.patch
parentbb5aa75b1d4c9589faf6dd1e1bba74f65a06656b (diff)
compat-mysql51: 5.1.73HEADmaster
Diffstat (limited to 'mysql-no-docs.patch')
-rw-r--r--mysql-no-docs.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/mysql-no-docs.patch b/mysql-no-docs.patch
new file mode 100644
index 0000000..a7aad64
--- /dev/null
+++ b/mysql-no-docs.patch
@@ -0,0 +1,40 @@
+Remove makefile logic dealing with mysql.info. We cannot ship that
+documentation since it is not freely redistributable.
+
+
+
+diff -up mysql-5.1.70/Docs/Makefile.am.p9 mysql-5.1.70/Docs/Makefile.am
+--- mysql-5.1.70/Docs/Makefile.am.p9 2013-05-13 15:33:33.000000000 +0200
++++ mysql-5.1.70/Docs/Makefile.am 2013-07-23 07:58:29.868617019 +0200
+@@ -13,28 +13,21 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+
+-EXTRA_DIST = mysql.info INSTALL-BINARY @extra_docs@
++EXTRA_DIST = INSTALL-BINARY @extra_docs@
+
+-# make sure that "make install" installs the info page, too
+-# automake only seems to take care of this automatically,
+-# if we're building the info page from texi directly.
+-install-data-hook: $(srcdir)/mysql.info
++install-data-hook:
+ if test `basename $(prefix)` = "mysql" ; then \
+ $(mkinstalldirs) $(DESTDIR)$(prefix)/docs ; \
+- $(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(prefix)/docs ; \
+ test ! -f $(top_srcdir)/ChangeLog || $(INSTALL_DATA) $(top_srcdir)/ChangeLog $(DESTDIR)$(prefix)/docs ; \
+ else \
+- $(mkinstalldirs) $(DESTDIR)$(infodir) $(DESTDIR)$(pkgdatadir) ; \
+- $(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(infodir) ; \
++ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir) ; \
+ test ! -f $(top_srcdir)/ChangeLog || $(INSTALL_DATA) $(top_srcdir)/ChangeLog $(DESTDIR)$(pkgdatadir) ; \
+ fi
+
+ uninstall-local:
+ if test `basename $(prefix)` = "mysql" ; then \
+- @RM@ -f $(DESTDIR)$(prefix)/docs/mysql.info ; \
+ @RM@ -f $(DESTDIR)$(prefix)/docs/ChangeLog ; \
+ else \
+- @RM@ -f $(DESTDIR)$(infodir)/mysql.info ; \
+ @RM@ -f $(DESTDIR)$(pkgdatadir)/ChangeLog ; \
+ fi
+