summaryrefslogtreecommitdiffstats
path: root/cassandra-cpp-driver.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cassandra-cpp-driver.spec')
-rw-r--r--cassandra-cpp-driver.spec20
1 files changed, 15 insertions, 5 deletions
diff --git a/cassandra-cpp-driver.spec b/cassandra-cpp-driver.spec
index b91f20a..c2a3757 100644
--- a/cassandra-cpp-driver.spec
+++ b/cassandra-cpp-driver.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for cassandra-cpp-driver
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit bb27c84bea51f84163d1a50e3e96c748a2cc583b
+%global gh_commit c97dd437c3730421f006dc4f2e36b533e405d357
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner datastax
%global gh_project cpp-driver
@@ -17,7 +17,7 @@
Name: cassandra-cpp-driver
Summary: DataStax C/C++ Driver for Apache Cassandra
-Version: 2.14.1%{?prever:~%{prever}}
+Version: 2.15.0%{?prever:~%{prever}}
Release: 1%{?dist}
License: ASL 2.0
Group: System Environment/Libraries
@@ -30,6 +30,7 @@ BuildRequires: gcc-c++
BuildRequires: cmake >= 2.6.4
BuildRequires: libuv-devel >= 1:1.0
BuildRequires: openssl-devel
+BuildRequires: krb5-devel
BuildRequires: zlib-devel
@@ -61,7 +62,11 @@ find examples -name .gitignore -exec rm {} \; -print
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
export CXXFLAGS="$RPM_OPT_FLAGS -Wno-implicit-fallthrough"
%endif
-%cmake
+%cmake \
+ -DCASS_USE_KERBEROS:BOOL=ON \
+ -DCASS_USE_OPENSSL:BOOL=ON \
+ -DCASS_INSTALL_HEADER_IN_SUBDIR:BOOL=ON \
+ .
make %{_smp_mflags}
@@ -86,11 +91,16 @@ make install DESTDIR="%{buildroot}"
%doc *.md
%doc examples
%{_libdir}/%{libname}.so
-%{_includedir}/cassandra.h
+%{_includedir}/cassandra/
%{_libdir}/pkgconfig/cassandra.pc
%changelog
+* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+- move headers in /usr/include/cassandra
+- enable Kerberos support
+
* Thu Dec 12 2019 Remi Collet <remi@remirepo.net> - 2.14.1-1
- update to 2.14.1