summaryrefslogtreecommitdiffstats
path: root/cassandra-cpp-driver.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cassandra-cpp-driver.spec')
-rw-r--r--cassandra-cpp-driver.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/cassandra-cpp-driver.spec b/cassandra-cpp-driver.spec
index 1db1e62..3b7ebb1 100644
--- a/cassandra-cpp-driver.spec
+++ b/cassandra-cpp-driver.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit c97dd437c3730421f006dc4f2e36b533e405d357
+%global gh_commit fafe4bf5e71af184582244552923a7a062c6144b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner datastax
%global gh_project cpp-driver
@@ -17,7 +17,7 @@
Name: cassandra-cpp-driver
Summary: DataStax C/C++ Driver for Apache Cassandra
-Version: 2.15.0%{?prever:~%{prever}}
+Version: 2.15.1%{?prever:~%{prever}}
Release: 1%{?dist}
License: ASL 2.0
Group: System Environment/Libraries
@@ -25,11 +25,9 @@ Group: System Environment/Libraries
URL: http://datastax.github.io/cpp-driver/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever:-%{prever}}-%{gh_short}.tar.gz
-Patch0: %{gh_project}-pc.patch
-
BuildRequires: gcc
BuildRequires: gcc-c++
-BuildRequires: cmake >= 2.6.4
+BuildRequires: cmake >= 2.8.12
BuildRequires: libuv-devel >= 1:1.0
BuildRequires: openssl-devel
BuildRequires: krb5-devel
@@ -56,8 +54,6 @@ for %{name}.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr465
-
find examples -name .gitignore -exec rm {} \; -print
@@ -69,6 +65,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS -Wno-implicit-fallthrough"
-DCASS_USE_KERBEROS:BOOL=ON \
-DCASS_USE_OPENSSL:BOOL=ON \
-DCASS_INSTALL_HEADER_IN_SUBDIR:BOOL=ON \
+ -DCASS_INSTALL_HEADER_SUBDIR_NAME:STRING="cassandra" \
.
make %{_smp_mflags}
@@ -99,6 +96,12 @@ make install DESTDIR="%{buildroot}"
%changelog
+* Wed Mar 18 2020 Remi Collet <remi@remirepo.net> - 2.15.1-1
+- update to 2.15.1
+- drop patch merged upstream
+- open https://github.com/datastax/cpp-driver/pull/472
+ fix CASS_INSTALL_HEADER_IN_SUBDIR usage
+
* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0
- move headers in /usr/include/cassandra