summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-16 16:03:03 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-16 16:03:03 +0100
commite302b5a0db6d5740344e61aba7d57dab6d34007d (patch)
tree5f7addd01308d7c563cc80d6ff62daae93cba24b
prototype: new package
-rw-r--r--.gitignore1
-rw-r--r--LICENSE16
-rw-r--r--Makefile4
-rw-r--r--prototype.conf14
-rw-r--r--prototype.spec74
5 files changed, 109 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..ccb38b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+prototype.js
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..05789cf
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,16 @@
+Copyright (c) 2005-2010 Sam Stephenson
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/prototype.conf b/prototype.conf
new file mode 100644
index 0000000..6936543
--- /dev/null
+++ b/prototype.conf
@@ -0,0 +1,14 @@
+Alias /prototype.js /usr/share/prototype/prototype.js
+
+<Directory /usr/share/prototype>
+ <IfModule mod_authz_core.c>
+ # Apache 2.4
+ Require all granted
+ </IfModule>
+ <IfModule !mod_authz_core.c>
+ # Apache 2.2
+ Order deny,allow
+ Allow from all
+ </IfModule>
+</Directory>
+
diff --git a/prototype.spec b/prototype.spec
new file mode 100644
index 0000000..fc3625b
--- /dev/null
+++ b/prototype.spec
@@ -0,0 +1,74 @@
+Name: prototype
+Version: 1.7.1.0
+Release: 1%{?dist}
+Summary: JavaScript framework
+Group: Applications/Internet
+License: MIT
+URL: http://www.prototypejs.org/
+
+# We cannot use the archive tarball from github
+# as we don't have yet requirement for build (rake, sprockets)
+Source0: https://ajax.googleapis.com/ajax/libs/prototype/%{version}/prototype.js
+Source1: https://raw.github.com/sstephenson/prototype/master/LICENSE
+Source2: prototype.conf
+
+BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildArch: noarch
+
+
+%description
+Prototype is a JavaScript framework that aims to ease development of dynamic
+web applications. It offers a familiar class-style OO framework, extensive
+Ajax support, higher-order programming constructs, and easy DOM manipulation.
+
+%package httpd
+Summary: Apache configuration for %{name}
+Group: Applications/Internet
+Requires: %{name} = %{version}-%{release}
+Requires: httpd
+
+%description httpd
+This package provides the Apache configuration for
+applications using an Alias to prototype library.
+
+
+%prep
+%setup -qcT
+
+cp -p %{SOURCE1} LICENSE
+
+
+%build
+# Nothing to build
+
+
+%install
+rm -rf %{buildroot}
+
+# JavaScript
+mkdir -p %{buildroot}%{_datadir}/%{name}
+cp -p %{SOURCE0} %{buildroot}%{_datadir}/%{name}/%{name}.js
+
+# Apache
+mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
+install -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE
+%{_datadir}/%{name}
+
+
+%files httpd
+%defattr(-,root,root,-)
+%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
+
+
+%changelog
+* Wed Jan 16 2013 Remi Collet <remi@fedoraproject.org> - 1.7.1.0-1
+- initial package