summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-12 16:51:50 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-12 16:51:50 +0100
commitdeb30582a5ec9e47830993e283ff9a3b35ce6c47 (patch)
tree67d2fb04bcf33e5bb16589df38a9c10308f9c85b
parent4156c67d2728eb0d9d0f12d58bdfa9448037ea4a (diff)
ckeditor: backport, improve, update...
-rw-r--r--ckeditor.conf13
-rw-r--r--ckeditor.spec53
2 files changed, 56 insertions, 10 deletions
diff --git a/ckeditor.conf b/ckeditor.conf
index eb90005..748db3e 100644
--- a/ckeditor.conf
+++ b/ckeditor.conf
@@ -1 +1,14 @@
Alias /ckeditor /usr/share/ckeditor
+
+<Directory /usr/share/ckeditor>
+ <IfModule mod_authz_core.c>
+ # Apache 2.4
+ Require all granted
+ </IfModule>
+ <IfModule !mod_authz_core.c>
+ # Apache 2.2
+ Order deny,allow
+ Allow from all
+ </IfModule>
+</Directory>
+
diff --git a/ckeditor.spec b/ckeditor.spec
index 2291968..c74bd15 100644
--- a/ckeditor.spec
+++ b/ckeditor.spec
@@ -1,5 +1,5 @@
Name: ckeditor
-Version: 3.6.4
+Version: 3.6.6
Release: 1%{?dist}
Summary: WYSIWYG text editor to be used inside web pages
@@ -8,10 +8,13 @@ License: GPLv2+ or LGPLv2+ or MPLv1.1+
URL: http://ckeditor.com/
Source0: http://download.cksource.com/CKEditor/CKEditor/CKEditor%20%{version}/ckeditor_%{version}.tar.gz
Source1: %{name}.conf
+
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildArch: noarch
Requires: httpd
+Requires: php-common
+
%description
CKEditor is a text editor to be used inside web pages. It's a WYSIWYG editor,
@@ -22,32 +25,62 @@ OpenOffice.
%prep
-%setup -q -n %{name}
+%setup -q -c
+
+# uneeded files
+rm -f %{name}/.htaccess
+rm -f %{name}/INSTALL.html
+rm -rf %{name}/_source
+
+# documentation
+mkdir doc
+mv %{name}/{CHANGES,LICENSE}.html doc/
+mv %{name}/_samples doc/
+
+# PHP Library
+mkdir php
+mv %{name}/*php php/
%build
+# Nothing to build
%install
-rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
-cp -rp * $RPM_BUILD_ROOT%{_datadir}/%{name}
-chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}/_samples/adobeair/run.sh
-mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
-install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
+rm -rf %{buildroot}
+
+# PHP
+mkdir -p %{buildroot}%{_datadir}/php/%{name}
+cp -p php/ckeditor_php5.php %{buildroot}%{_datadir}/php/%{name}/ckeditor.php
+
+# Javascript
+cp -rp %{name} %{buildroot}%{_datadir}/%{name}
+
+# Apache
+mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
+install -p -m 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/httpd/conf.d
+
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc CHANGES.html INSTALL.html LICENSE.html
+%doc doc/*
%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
%{_datadir}/%{name}
+%{_datadir}/php/%{name}
%changelog
+* Sat Jan 13 2013 Remi Collet <RPMS@FamilleCollet.com> - 3.6.6-1
+- backport for remi repo
+- update to 3.6.6
+- move _samples in doc
+- don't package _source
+- move php library to /usr/share/php
+
* Fri Sep 14 2012 Orion Poplawski <orion@cora.nwra.com> 3.6.4-1
- Update to 3.6.4