summaryrefslogtreecommitdiffstats
path: root/glpi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'glpi.spec')
-rw-r--r--glpi.spec45
1 files changed, 35 insertions, 10 deletions
diff --git a/glpi.spec b/glpi.spec
index 3640125..d5f6eeb 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -1,13 +1,13 @@
# Fedora/remirepo spec file for glpi
#
-# Copyright (c) 2007-2019 Remi Collet
+# Copyright (c) 2007-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 081338b2fa3a98eacb6f7ca380714f34ec0266ff
+%global gh_commit 7fbee4f15b37c98f6f2078bd10634ef02b5edc25
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -52,10 +52,10 @@
%endif
Name: %{gh_project}
-%global upstream_version 9.4.3
+%global upstream_version 9.4.6
#global upstream_prever RC2
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -109,7 +109,7 @@ BuildRequires: (php-composer(symfony/console) >= 3.4 with php
BuildRequires: (php-composer(leafo/scssphp) >= 0.7.7 with php-composer(leafo/scssphp) < 1)
# requires-dev
BuildRequires: (php-composer(guzzlehttp/guzzle) >= 6 with php-composer(guzzlehttp/guzzle) < 7)
-BuildRequires: (php-composer(atoum/atoum) >= 3.3 with php-composer(atoum/atoum) < 4)
+BuildRequires: (php-composer(atoum/atoum) >= 3.4 with php-composer(atoum/atoum) < 4)
BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
# remirepo:40
%else
@@ -148,7 +148,7 @@ BuildRequires: php-symfony3-console >= 3.4
BuildRequires: php-composer(guzzlehttp/guzzle) < 7
BuildRequires: php-composer(guzzlehttp/guzzle) >= 6
BuildRequires: php-composer(atoum/atoum) < 4
-BuildRequires: php-composer(atoum/atoum) >= 3.3
+BuildRequires: php-composer(atoum/atoum) >= 3.4
BuildRequires: php-composer(mikey179/vfsStream) < 2
BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
%endif
@@ -449,7 +449,7 @@ rm composer.lock
: Add developement dependecies
cat << 'EOF' | tee -a vendor/autoload.php
\Fedora\Autoloader\Dependencies::required([
- // "guzzlehttp/guzzle": "~6"
+ // "guzzlehttp/guzzle": "^6.0"
"$vendor/GuzzleHttp6/autoload.php",
"$vendor/org/bovigo/vfs/autoload.php",
]);
@@ -460,7 +460,7 @@ export GLPI_SKIP_ONLINE=1
: Running a PHP server
export GLPI_URI=http://127.0.0.1:8089
-%{_bindir}/php -S 127.0.0.1:8089 tests/router.php &>web.log &
+php -S 127.0.0.1:8089 tests/router.php &>web.log &
PHPPID=$!
: Running a MariaDB server
@@ -468,6 +468,11 @@ MYSQL_TEST_HOST=127.0.0.1
MYSQL_TEST_PORT=3308
MYSQL_TEST_SOCKET=$PWD/mysql.sock
MYSQL_PID_FILE=$PWD/mysql.pid
+%if 0%{?fedora} >= 32
+MYSQL_USER=mockbuild
+%else
+MYSQL_USER=root
+%endif
rm -rf data
mkdir data
@@ -487,7 +492,7 @@ mkdir data
n=15
while [ $n -gt 0 ]; do
- RESPONSE=$(%{_bindir}/mysqladmin --no-defaults --socket="$MYSQL_TEST_SOCKET" --user=root ping 2>&1 || :)
+ RESPONSE=$(%{_bindir}/mysqladmin --no-defaults --socket="$MYSQL_TEST_SOCKET" --user=$MYSQL_USER ping 2>&1 || :)
if [ "$RESPONSE" == "mysqld is alive" ]; then
break
fi
@@ -499,7 +504,7 @@ done
cp %{SOURCE12} inc/downstream.php
: Run upstream test suite
-bin/console.rpm glpi:database:install --config-dir=./tests --no-interaction --db-host=127.0.0.1:3308 --db-name=glpitest --db-user=root --force || RET=1
+bin/console.rpm glpi:database:install --config-dir=./tests --no-interaction --db-port=$MYSQL_TEST_SOCKET --db-name=glpitest --db-user=$MYSQL_USER --force || RET=1
: Ignore test which raise memory issue
rm tests/functionnal/Search.php
@@ -610,6 +615,26 @@ fi
%changelog
+* Tue May 05 2020 Johan Cwiklinski <jcwiklinski AT teclib DOT com> - 9.4.6-1
+- update to 9.4.6
+- drop patches applied upstream
+
+* Mon Feb 10 2020 Remi Collet <remi@remirepo.net> - 9.4.5-3
+- switch test suite on UDS using patch from
+ https://github.com/glpi-project/glpi/pull/6921
+ fix FTBFS with mariadb 10.4 #1799419
+
+* Thu Jan 9 2020 Remi Collet <remi@remirepo.net> - 9.4.5-2
+- add upstream patches for PHP 7.4
+- re-enable test suite
+
+* Wed Dec 18 2019 Remi Collet <remi@remirepo.net> - 9.4.5-1
+- update to 9.4.5
+- disable test suite with PHP 7.4
+
+* Tue Sep 24 2019 Remi Collet <remi@remirepo.net> - 9.4.4-1
+- update to 9.4.4
+
* Fri Jul 19 2019 Remi Collet <remi@remirepo.net> - 9.4.3-2
- allow elvanto/litemoji 2.0
see https://github.com/glpi-project/glpi/pull/6141