summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json11
-rw-r--r--glpi-fedora-autoloader.php1
-rw-r--r--glpi.spec9
3 files changed, 17 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index 9ba359c..99afa58 100644
--- a/composer.json
+++ b/composer.json
@@ -27,6 +27,7 @@
"tecnickcom/tcpdf": "~6.2",
"zendframework/zend-cache": "^2.7",
"zendframework/zend-i18n": "^2.7",
+ "zendframework/zend-serializer": "^2.7",
"michelf/php-markdown": "^1.6",
"true/punycode": "^2.1",
"paragonie/random_compat": "^2.0"
@@ -37,7 +38,8 @@
"consolidation/robo": "^1.0",
"natxet/CssMin": "^3.0",
"patchwork/jsqueeze": "^2.0",
- "atoum/atoum": "^3.2"
+ "atoum/atoum": "^3.2",
+ "atoum/telemetry-extension": "^1.0"
},
"suggest": {
"ext-ldap": "Used ot provide LDAP authentication and synchronization",
@@ -50,8 +52,11 @@
}
},
"scripts": {
- "test": "vendor/bin/atoum --debug --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/units",
- "testapi": "vendor/bin/atoum --debug --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/api",
+ "testdb": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/database",
+ "test": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/units",
+ "testweb": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/web",
+ "testldap": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/LDAP",
+ "cs": "vendor/bin/phpcs -p --standard=vendor/glpi-project/coding-standard/GlpiStandard/ --ignore=/vendor/,/plugins/,/files/,/lib/,/config/,/tests/config ./",
"post-install-cmd": [
"@php -r \"file_put_contents('.composer.hash', sha1_file('composer.lock'));\""
],
diff --git a/glpi-fedora-autoloader.php b/glpi-fedora-autoloader.php
index a9ea4fa..808881d 100644
--- a/glpi-fedora-autoloader.php
+++ b/glpi-fedora-autoloader.php
@@ -16,6 +16,7 @@ require_once $vendor . '/php-simplepie/autoloader.php';
require_once $vendor . '/tcpdf/autoload.php';
// "zendframework/zend-cache": "^2.7",
// "zendframework/zend-i18n": "^2.7",
+// "zendframework/zend-serializer": "^2.7",
require_once $vendor . '/Zend/autoload.php';
// "michelf/php-markdown": "^1.6",
require_once $vendor . '/Michelf/markdown-autoload.php';
diff --git a/glpi.spec b/glpi.spec
index 10be8f3..c4fc2f2 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -43,7 +43,7 @@
Name: %{gh_project}
Version: 9.2.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -91,6 +91,8 @@ BuildRequires: php-composer(zendframework/zend-cache) < 3
BuildRequires: php-composer(zendframework/zend-cache) >= 2.7
BuildRequires: php-composer(zendframework/zend-i18n) < 3
BuildRequires: php-composer(zendframework/zend-i18n) >= 2.7
+BuildRequires: php-composer(zendframework/zend-serializer) < 3
+BuildRequires: php-composer(zendframework/zend-serializer) >= 2.7
BuildRequires: php-composer(michelf/php-markdown) < 2
BuildRequires: php-composer(michelf/php-markdown) >= 1.6
BuildRequires: php-composer(true/punycode) < 3
@@ -159,6 +161,8 @@ Requires: php-composer(zendframework/zend-cache) < 3
Requires: php-composer(zendframework/zend-cache) >= 2.7
Requires: php-composer(zendframework/zend-i18n) < 3
Requires: php-composer(zendframework/zend-i18n) >= 2.7
+Requires: php-composer(zendframework/zend-serializer) < 3
+Requires: php-composer(zendframework/zend-serializer) >= 2.7
Requires: php-composer(zendframework/zend-loader)
Requires: php-composer(michelf/php-markdown) < 2
Requires: php-composer(michelf/php-markdown) >= 1.6
@@ -498,6 +502,9 @@ fi
%changelog
+* Thu Nov 16 2017 Remi Collet <remi@remirepo.net> - 9.2.1-2
+- add dependency on zendframework/zend-serializer
+
* Thu Nov 16 2017 Remi Collet <remi@remirepo.net> - 9.2.1-1
- update to 9.2.1