summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-29 14:09:59 +0200
committerRemi Collet <remi@remirepo.net>2018-06-29 14:09:59 +0200
commit904b4e941f164da11a233f0825b4552bb089e89a (patch)
tree88e54750e6c8774a018e1656264052c450c9d906
parent77aca372fc8feea9445eb1b3d86a9cac83e2be34 (diff)
fix cannot retrieve GLPI configuration when personalized upstream from https://forge.glpi-project.org/issues/5565glpi92
-rw-r--r--changeset_r458.diff18
-rw-r--r--glpi-webservices.spec16
2 files changed, 30 insertions, 4 deletions
diff --git a/changeset_r458.diff b/changeset_r458.diff
new file mode 100644
index 0000000..13740e3
--- /dev/null
+++ b/changeset_r458.diff
@@ -0,0 +1,18 @@
+Index: trunk/inc/methodsession.class.php
+===================================================================
+--- trunk/inc/methodsession.class.php (révision 457)
++++ trunk/inc/methodsession.class.php (révision 458)
+@@ -339,12 +339,7 @@
+ $current = session_id();
+ $session = trim($session);
+
+- if (file_exists(GLPI_ROOT . "/config/config_path.php")) {
+- include_once (GLPI_ROOT . "/config/config_path.php");
+- }
+- if (!defined("GLPI_SESSION_DIR")) {
+- define("GLPI_SESSION_DIR", GLPI_ROOT . "/files/_sessions");
+- }
++ require_once GLPI_ROOT . '/inc/based_config.php';
+
+ if ($session != $current) {
+ if (!empty($current)) {
diff --git a/glpi-webservices.spec b/glpi-webservices.spec
index b60c0df..479fca7 100644
--- a/glpi-webservices.spec
+++ b/glpi-webservices.spec
@@ -10,7 +10,7 @@
Name: glpi-webservices
Version: 1.8.0
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: GLPI Plugin which provides web services
Summary(fr): Extension GLPI fournissant des services web
@@ -19,6 +19,8 @@ URL: https://forge.glpi-project.org/projects/webservices
Source0: https://forge.glpi-project.org/attachments/download/2248/glpi-webservices-1.8.0.tar.gz
+Patch0: changeset_r458.diff
+
BuildArch: noarch
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -43,10 +45,12 @@ Cette extension fournit un serveur de services web permettant
%prep
%setup -q -c
-rm -rf %{pluginname}/.htaccess \
- %{pluginname}/scripts/.htaccess
+cd %{pluginname}
+grep version_compare setup.php
+%patch0 -p1
-rm -rf %{pluginname}/tools
+rm -r .htaccess scripts/.htaccess
+cd ..
# Create link to LICENSE for standard doc folder
ln -s %{_datadir}/glpi/plugins/%{pluginname}/LICENSE LICENSE
@@ -92,6 +96,10 @@ install --mode 644 httpd %{buildroot}/%{_sysconfdir}/httpd/conf.d/%{name}.conf
%changelog
+* Fri Jun 29 2018 Remi Collet <remi@remirepo.net> - 1.8.0-3
+- fix cannot retrieve GLPI configuration when personalized
+ upstream from https://forge.glpi-project.org/issues/5565
+
* Tue Jun 12 2018 Remi Collet <remi@remirepo.net> - 1.8.0-2
- allow GLPI 9.3