summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-03 16:34:07 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-03 16:34:07 +0200
commit00c88393fe363fa4219f44e569f5bf8a9d30058a (patch)
tree82778eee7ee69fb21508c45c9b572ad0f05c0d6d
parent2eaff9d03fe967e85b8458e705f31031771319f8 (diff)
glpi-reports: upstream patches for 'doublon'
-rw-r--r--changeset_r322.diff16
-rw-r--r--changeset_r323.diff13
-rw-r--r--glpi-reports.spec11
3 files changed, 39 insertions, 1 deletions
diff --git a/changeset_r322.diff b/changeset_r322.diff
new file mode 100644
index 0000000..3d7452b
--- /dev/null
+++ b/changeset_r322.diff
@@ -0,0 +1,16 @@
+Index: trunk/report/doublons/doublons.php
+===================================================================
+--- trunk/report/doublons/doublons.php (révision 321)
++++ trunk/report/doublons/doublons.php (révision 322)
+@@ -75,11 +75,6 @@
+ echo "<tr class='tab_bg_1 center'>";
+ echo "<th colspan='3'>".__('Duplicate computers', 'reports')."</th></tr>\n";
+
+-if (Session::haveRight("config", READ)) { // Check only read as we probably use the replicate (no 'w' in this case)
+- echo "<tr class='tab_bg_3 center'><td colspan='".(($crit > 0)?'3':'2')."'>";
+- echo "<a href='./doublons.config.php'>".__('Report configuration', 'reports')."</a></td></tr>\n";
+-}
+-
+ echo "<tr class='tab_bg_1'><td class='right'>"._n('Criterion', 'Criteria', 2). "</td><td>";
+ echo "<select name='crit'>";
+
diff --git a/changeset_r323.diff b/changeset_r323.diff
new file mode 100644
index 0000000..5d96b93
--- /dev/null
+++ b/changeset_r323.diff
@@ -0,0 +1,13 @@
+Index: trunk/report/doublons/doublons.php
+===================================================================
+--- trunk/report/doublons/doublons.php (révision 322)
++++ trunk/report/doublons/doublons.php (révision 323)
+@@ -206,7 +206,7 @@
+ $SerialBlacklist = "''";
+
+ $res = $DB->query("SELECT `value`
+- FROM `glpi__blacklists`
++ FROM `glpi_blacklists`
+ WHERE `type` = '3'");
+ while ($data = $DB->fetch_array($res)) {
+ $SerialBlacklist .= ",'".addslashes($data["value"])."'";
diff --git a/glpi-reports.spec b/glpi-reports.spec
index a9630ea..b2c2fc4 100644
--- a/glpi-reports.spec
+++ b/glpi-reports.spec
@@ -20,6 +20,10 @@ URL: https://forge.glpi-project.org/projects/reports
Source0: https://forge.glpi-project.org/attachments/download/2101/glpi-reports-1.9.0.tar.gz
+# Upstream patches
+Patch1: changeset_r322.diff
+Patch2: changeset_r323.diff
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: gettext
@@ -51,7 +55,12 @@ Fonctionnalités principales :
%prep
%setup -q -c
-rm -r %{pluginname}/tools
+pushd %{pluginname}
+%patch1 -p1
+%patch2 -p1
+
+rm -rf tools
+popd
# Create link to LICENSE for standard doc folder
ln -s %{_datadir}/glpi/plugins/%{pluginname}/LICENSE LICENSE