summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-30 07:48:49 +0100
committerRemi Collet <remi@remirepo.net>2018-11-30 07:48:49 +0100
commit317bd37c4f06c73901010d8fba72523cd10c84f2 (patch)
tree3066a9d638ddf9d4afe3890a796dc135c820ad66
new package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--glpi-archires.spec101
3 files changed, 113 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/glpi-archires.spec b/glpi-archires.spec
new file mode 100644
index 0000000..e3d30e7
--- /dev/null
+++ b/glpi-archires.spec
@@ -0,0 +1,101 @@
+# remirepo spec file for glpi-archires
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global pluginname archires
+
+Name: glpi-archires
+Version: 2.6.0
+Release: 1%{?dist}
+Summary: Network architecture
+
+License: AGPLv3+
+URL: https://forge.glpi-project.org/projects/archires
+
+Source0: https://forge.glpi-project.org/attachments/download/2265/glpi-archires-2.6.0.tar.gz
+
+BuildArch: noarch
+BuildRequires: gettext
+
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (glpi >= 9.3 with glpi < 9.4)
+%else
+Requires: glpi >= 9.3
+Requires: glpi < 9.4
+%endif
+Requires: graphviz
+
+
+%description
+This plugin allow you to generate automatically a graphical representation
+of the network architecture.
+
+Filters :
+- by equipment type,
+- by states,
+- by network
+- by VLAN
+- by groups
+
+Setup :
+- association of pics with types of equipment
+- association of colors with types of networks,
+- association of colors with status of equipments,
+- association of colors with VLANs
+
+
+
+%prep
+%setup -q -c
+
+# Create link to LICENSE for standard doc folder
+ln -s %{_datadir}/glpi/plugins/%{pluginname}/LICENSE LICENSE
+
+# For developer only
+rm -rf %{pluginname}/tools
+
+# Display compatibility check
+grep version_compare %{pluginname}/setup.php
+
+
+%build
+# Regenerate the locales
+for po in %{pluginname}/locales/*.po
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+
+%install
+mkdir -p %{buildroot}/%{_datadir}/glpi/plugins
+cp -ar %{pluginname} %{buildroot}/%{_datadir}/glpi/plugins/%{pluginname}
+
+for i in %{buildroot}/%{_datadir}/glpi/plugins/%{pluginname}/locales/*
+do
+ lang=$(basename $i)
+ echo "%lang(${lang:0:2}) %{_datadir}/glpi/plugins/%{pluginname}/locales/${lang}"
+done | tee %{name}.lang
+
+
+%files -f %{name}.lang
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%dir %{_datadir}/glpi/plugins/%{pluginname}
+%dir %{_datadir}/glpi/plugins/%{pluginname}/locales
+%{_datadir}/glpi/plugins/%{pluginname}/*.php
+%{_datadir}/glpi/plugins/%{pluginname}/ajax
+%{_datadir}/glpi/plugins/%{pluginname}/front
+%{_datadir}/glpi/plugins/%{pluginname}/inc
+%{_datadir}/glpi/plugins/%{pluginname}/pics
+%{_datadir}/glpi/plugins/%{pluginname}/sql
+# Keep here as required from interface
+%{_datadir}/glpi/plugins/%{pluginname}/LICENSE
+
+
+%changelog
+* Fri Nov 30 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- Initial RPM, version 2.6.0 for GLPI 9.3