summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-08-16 20:02:35 +0200
committerRemi Collet <fedora@famillecollet.com>2010-08-16 20:02:35 +0200
commitb1a79c4da6d47dec27f0fb8c9423bd6a1457ed24 (patch)
treed43f9b1a94a7b7b61a21a3446067199770ea47e9
parent17251d433ab18f59dab060e3ebadef6367969943 (diff)
fusioninventory-agent, fix perl filter for old distro
-rw-r--r--fusioninventory-agent.spec19
1 files changed, 15 insertions, 4 deletions
diff --git a/fusioninventory-agent.spec b/fusioninventory-agent.spec
index 9eccbc0..6803cc3 100644
--- a/fusioninventory-agent.spec
+++ b/fusioninventory-agent.spec
@@ -40,11 +40,13 @@ Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig, /sbin/service
Requires(postun): /sbin/service
-%{?filter_setup:
-%filter_from_requires /perl(Win32/d
-%?perl_default_filter
-}
+%{?perl_default_filter}
+# This work only on recent fedora
+#{?filter_setup:
+#filter_from_requires /perl(Win32/d
+#?perl_default_filter
+#}
%description
FusionInventory Agent is an application designed to help a network
@@ -90,6 +92,15 @@ Vous pouvez ajouter les paquets additionnels pour les tâches optionnelles :
%setup -q -n FusionInventory-Agent-%{version}
%endif
+cat <<EOF | tee %{name}-req
+#!/bin/sh
+%{__perl_requires} $* | \
+sed -e '/perl(Win32/d'
+EOF
+
+%global __perl_requires %{_builddir}/FusionInventory-Agent-%{version}/%{name}-req
+chmod +x %{__perl_requires}
+
%patch0 -p0
cat <<EOF | tee logrotate