summaryrefslogtreecommitdiffstats
path: root/composer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'composer.spec')
-rw-r--r--composer.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/composer.spec b/composer.spec
index e110249..04b8cc5 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,17 +6,17 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 92faf1c7a83a73794fb914a990be435e1df373ca
+%global gh_commit 00c26791faeb83da8476b54bcc20596cf754362e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
-%global gh_date 20150714
+%global gh_date 20150720
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: composer
Version: 1.0.0
-Release: 0.7.%{gh_date}git%{gh_short}%{?dist}
+Release: 0.8.%{gh_date}git%{gh_short}%{?dist}
Summary: Dependency Manager for PHP
Group: Development/Libraries
@@ -31,14 +31,12 @@ Patch0: %{name}-rpm.patch
# https://github.com/composer/composer/pull/4169
# skip online tests
Patch1: %{name}-pr4169.patch
-# https://github.com/composer/composer/pull/4262
-# fix for tests
-Patch2: %{name}-pr4262.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
BuildRequires: php-composer(justinrainbow/json-schema) >= 1.4.4
+BuildRequires: php-composer(composer/spdx-licenses) >= 1.0
BuildRequires: php-composer(seld/jsonlint) >= 1.0
BuildRequires: php-composer(symfony/console) >= 2.5
BuildRequires: php-composer(symfony/finder) >= 2.2
@@ -51,6 +49,7 @@ BuildRequires: php-zip
# From composer.json, requires
# "php": ">=5.3.2",
# "justinrainbow/json-schema": "^1.4.4",
+# "composer/spdx-licenses": "~1.0",
# "seld/jsonlint": "~1.0",
# "symfony/console": "~2.5",
# "symfony/finder": "~2.2",
@@ -61,6 +60,8 @@ Requires: php(language) >= 5.3.2
Requires: php-cli
Requires: php-composer(justinrainbow/json-schema) >= 1.4.4
Requires: php-composer(justinrainbow/json-schema) < 2
+Requires: php-composer(composer/spdx-licenses) >= 1.0
+Requires: php-composer(composer/spdx-licenses) < 2
Requires: php-composer(seld/jsonlint) >= 1.0
Requires: php-composer(seld/jsonlint) < 2
Requires: php-composer(seld/phar-utils) >= 1.0
@@ -115,7 +116,6 @@ Documentation: https://getcomposer.org/doc/
%patch0 -p1
%patch1 -p1
-%patch2 -p1
cp -p %{SOURCE1} src/Composer/autoload.php
cp -p %{SOURCE2} tests/bootstrap.php
@@ -175,6 +175,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Jul 21 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.8.20150720git00c2679
+- new snapshot
+- add dependency on composer/spdx-licenses
+
* Thu Jul 16 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.7.20150714git92faf1c
- new snapshot
- raise dependency on justinrainbow/json-schema 1.4.4