summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.spec11
-rw-r--r--installed.json31
2 files changed, 23 insertions, 19 deletions
diff --git a/composer.spec b/composer.spec
index f577223..e3e83c5 100644
--- a/composer.spec
+++ b/composer.spec
@@ -18,7 +18,7 @@
%bcond_with syslib
%endif
-%global gh_commit c3777ea50f5ad561d4796b42fba4d180bb45cf77
+%global gh_commit b0024890b8650e52d1a29822856b3c95aa393785
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -26,7 +26,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.3.2
+%global upstream_version 2.3.3
#global upstream_prever RC2
#global upstream_lower rc2
@@ -164,14 +164,14 @@ Requires: ca-certificates
Provides: bundled(php-composer-ca-bundle) = 1.3.1
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.0.0
-Provides: bundled(php-composer-semver) = 3.3.1
+Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-spdx-licenses) = 1.5.6
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-justinrainbow-json-schema) = 5.2.11
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.9.0
-Provides: bundled(php-seld-jsonlint) = 1.8.3
+Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.0
Provides: bundled(php-symfony-console) = v5.4.5
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
@@ -413,6 +413,9 @@ exit $ret
%changelog
+* Sat Apr 2 2022 Remi Collet <remi@remirepo.net> - 2.3.3-1
+- update to 2.3.3
+
* Thu Mar 31 2022 Remi Collet <remi@remirepo.net> - 2.3.2-1
- update to 2.3.2
diff --git a/installed.json b/installed.json
index 07abc37..09f1604 100644
--- a/installed.json
+++ b/installed.json
@@ -227,17 +227,17 @@
},
{
"name": "composer/semver",
- "version": "3.3.1",
- "version_normalized": "3.3.1.0",
+ "version": "3.3.2",
+ "version_normalized": "3.3.2.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "5d8e574bb0e69188786b8ef77d43341222a41a71"
+ "reference": "3953f23262f2bff1919fc82183ad9acb13ff62c9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/5d8e574bb0e69188786b8ef77d43341222a41a71",
- "reference": "5d8e574bb0e69188786b8ef77d43341222a41a71",
+ "url": "https://api.github.com/repos/composer/semver/zipball/3953f23262f2bff1919fc82183ad9acb13ff62c9",
+ "reference": "3953f23262f2bff1919fc82183ad9acb13ff62c9",
"shasum": ""
},
"require": {
@@ -247,7 +247,7 @@
"phpstan/phpstan": "^1.4",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2022-03-16T11:22:07+00:00",
+ "time": "2022-04-01T19:23:25+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -291,7 +291,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.3.1"
+ "source": "https://github.com/composer/semver/tree/3.3.2"
},
"funding": [
{
@@ -719,26 +719,27 @@
},
{
"name": "seld/jsonlint",
- "version": "1.8.3",
- "version_normalized": "1.8.3.0",
+ "version": "1.9.0",
+ "version_normalized": "1.9.0.0",
"source": {
"type": "git",
"url": "https://github.com/Seldaek/jsonlint.git",
- "reference": "9ad6ce79c342fbd44df10ea95511a1b24dee5b57"
+ "reference": "4211420d25eba80712bff236a98960ef68b866b7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/Seldaek/jsonlint/zipball/9ad6ce79c342fbd44df10ea95511a1b24dee5b57",
- "reference": "9ad6ce79c342fbd44df10ea95511a1b24dee5b57",
+ "url": "https://api.github.com/repos/Seldaek/jsonlint/zipball/4211420d25eba80712bff236a98960ef68b866b7",
+ "reference": "4211420d25eba80712bff236a98960ef68b866b7",
"shasum": ""
},
"require": {
"php": "^5.3 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0"
+ "phpstan/phpstan": "^1.5",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0 || ^8.5.13"
},
- "time": "2020-11-11T09:19:24+00:00",
+ "time": "2022-04-01T13:37:23+00:00",
"bin": [
"bin/jsonlint"
],
@@ -769,7 +770,7 @@
],
"support": {
"issues": "https://github.com/Seldaek/jsonlint/issues",
- "source": "https://github.com/Seldaek/jsonlint/tree/1.8.3"
+ "source": "https://github.com/Seldaek/jsonlint/tree/1.9.0"
},
"funding": [
{