summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-rpm.patch44
-rw-r--r--composer.spec25
2 files changed, 36 insertions, 33 deletions
diff --git a/composer-rpm.patch b/composer-rpm.patch
index 9ac2a38..e16d05d 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2015-09-20 20:44:55.000000000 +0200
-+++ ./bin/composer 2015-09-21 17:38:08.532640919 +0200
+--- ./bin/composer.rpm 2015-12-15 10:35:39.000000000 +0100
++++ ./bin/composer 2015-12-15 16:14:05.574860901 +0100
@@ -5,7 +5,7 @@ if (PHP_SAPI !== 'cli') {
echo 'Warning: Composer should be invoked via the CLI version of PHP, not the '.PHP_SAPI.' SAPI'.PHP_EOL;
}
@@ -11,33 +11,21 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2015-09-21 17:38:08.532640919 +0200
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2015-09-21 17:38:58.418873383 +0200
-@@ -290,7 +290,7 @@ EOF;
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2015-12-15 16:14:05.575860906 +0100
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2015-12-15 16:14:18.054913016 +0100
+@@ -287,7 +287,7 @@ EOF;
file_put_contents($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader));
$this->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
- $this->safeCopy(__DIR__.'/../../../LICENSE', $targetDir.'/LICENSE');
+ $this->safeCopy((getenv('BUILDROOT')?:'') . '/usr/share/composer/LICENSE', $targetDir.'/LICENSE');
- $this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
- 'optimize' => (bool) $scanPsr0Packages,
-diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2015-09-20 20:44:55.000000000 +0200
-+++ ./src/Composer/Json/JsonFile.php 2015-09-21 17:38:08.532640919 +0200
-@@ -149,7 +149,7 @@ class JsonFile
- self::validateSyntax($content, $this->path);
- }
-
-- $schemaFile = __DIR__ . '/../../../res/composer-schema.json';
-+ $schemaFile = (getenv('BUILDROOT')?:'') . '/usr/share/composer/res/composer-schema.json';
- $schemaData = json_decode(file_get_contents($schemaFile));
-
- if ($schema === self::LAX_SCHEMA) {
+ if ($this->runScripts) {
+ $this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
diff -up ./src/Composer/Command/DiagnoseCommand.php.rpm ./src/Composer/Command/DiagnoseCommand.php
---- ./src/Composer/Command/DiagnoseCommand.php.rpm 2015-10-07 12:05:33.000000000 +0200
-+++ ./src/Composer/Command/DiagnoseCommand.php 2015-10-11 19:45:58.427641279 +0200
-@@ -132,9 +132,6 @@
+--- ./src/Composer/Command/DiagnoseCommand.php.rpm 2015-12-15 10:35:39.000000000 +0100
++++ ./src/Composer/Command/DiagnoseCommand.php 2015-12-15 16:14:05.575860906 +0100
+@@ -132,9 +132,6 @@ EOT
$io->write('Checking disk free space: ', false);
$this->outputResult($this->checkDiskSpace($config));
@@ -47,3 +35,15 @@ diff -up ./src/Composer/Command/DiagnoseCommand.php.rpm ./src/Composer/Command/D
return $this->failures;
}
+diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
+--- ./src/Composer/Json/JsonFile.php.rpm 2015-12-15 10:35:39.000000000 +0100
++++ ./src/Composer/Json/JsonFile.php 2015-12-15 16:14:05.575860906 +0100
+@@ -149,7 +149,7 @@ class JsonFile
+ self::validateSyntax($content, $this->path);
+ }
+
+- $schemaFile = __DIR__ . '/../../../res/composer-schema.json';
++ $schemaFile = (getenv('BUILDROOT')?:'') . '/usr/share/composer/res/composer-schema.json';
+ $schemaData = json_decode(file_get_contents($schemaFile));
+
+ if ($schema === self::LAX_SCHEMA) {
diff --git a/composer.spec b/composer.spec
index 92b945f..68cd0c1 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,19 +6,19 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit cd9054ce2abd1d06ed0eb1244eba1b2c2af633b6
+%global gh_commit f25446e507a3f420b2b88e6dedc47787d42ea7e9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_branch 1.0-dev
-#global gh_date 20151114
+%global gh_branch 1.0-dev
+%global gh_date 20151215
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global api_version 1.0.0
-%global prever alpha11
+#global prever alpha11
Name: composer
Version: 1.0.0
-Release: 0.15.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}%{?dist}
+Release: 0.16.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}%{?dist}
Summary: Dependency Manager for PHP
Group: Development/Libraries
@@ -38,7 +38,7 @@ BuildRequires: php-cli
BuildRequires: php-composer(justinrainbow/json-schema) >= 1.4.4
BuildRequires: php-composer(composer/spdx-licenses) >= 1.0
BuildRequires: php-composer(composer/semver) >= 1.0
-BuildRequires: php-composer(seld/jsonlint) >= 1.0
+BuildRequires: php-composer(seld/jsonlint) >= 1.4
BuildRequires: php-composer(seld/phar-utils) >= 1.0
BuildRequires: php-composer(seld/cli-prompt) >= 1.0
BuildRequires: php-composer(symfony/console) >= 2.5
@@ -54,7 +54,6 @@ BuildRequires: php-composer(phpunit/phpunit) >= 4.5
BuildRequires: php-composer(symfony/class-loader)
BuildRequires: php-seld-phar-utils >= 1.0.1
BuildRequires: php-seld-cli-prompt >= 1.0.0-3
-BuildRequires: php-jsonlint >= 1.3.1-3
%endif
@@ -63,7 +62,7 @@ BuildRequires: php-jsonlint >= 1.3.1-3
# "justinrainbow/json-schema": "^1.4.4",
# "composer/spdx-licenses": "^1.0",
# "composer/semver": "^1.0",
-# "seld/jsonlint": "~1.0",
+# "seld/jsonlint": "~1.4",
# "symfony/console": "^2.5 || ^3.0",
# "symfony/finder": "^2.2 || ^3.0",
# "symfony/process": "^2.1 || ^3.0",
@@ -78,7 +77,7 @@ Requires: php-composer(composer/spdx-licenses) >= 1.0
Requires: php-composer(composer/spdx-licenses) < 2
Requires: php-composer(composer/semver) >= 1.0
Requires: php-composer(composer/semver) < 2
-Requires: php-composer(seld/jsonlint) >= 1.0
+Requires: php-composer(seld/jsonlint) >= 1.4
Requires: php-composer(seld/jsonlint) < 2
Requires: php-composer(seld/phar-utils) >= 1.0
Requires: php-composer(seld/phar-utils) < 2
@@ -101,7 +100,6 @@ Requires: php-openssl
Requires: php-composer(symfony/class-loader)
Requires: php-seld-phar-utils >= 1.0.1
Requires: php-seld-cli-prompt >= 1.0.0-3
-Requires: php-jsonlint >= 1.3.1-3
# From phpcompatinfo
Requires: php-curl
Requires: php-date
@@ -138,7 +136,8 @@ Documentation: https://getcomposer.org/doc/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
+%patch0 -p1 -b .rpm
+find . -name \*.rpm -exec rm {} \; -print
cp -p %{SOURCE1} src/Composer/autoload.php
cp -p %{SOURCE2} tests/bootstrap.php
@@ -219,6 +218,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Dec 15 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.16.20151215gitf25446e
+- new snapshot
+- raise dependency on seld/jsonlint ^1.4
+
* Sat Nov 14 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.15.alpha1
- update to 1.0.0alpha11
- run test suite with both PHP 5 and 7 when available