summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-rpm.patch38
-rw-r--r--composer.spec9
2 files changed, 44 insertions, 3 deletions
diff --git a/composer-rpm.patch b/composer-rpm.patch
index 5572b1a..689ceac 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -68,3 +68,41 @@ diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/
if (!$validator->isValid()) {
$errors = $validator->getErrors();
+diff -up ./tests/Composer/Test/PolyfillTestCase.php.rpm ./tests/Composer/Test/PolyfillTestCase.php
+--- ./tests/Composer/Test/PolyfillTestCase.php.rpm 2020-10-15 10:22:22.286612967 +0200
++++ ./tests/Composer/Test/PolyfillTestCase.php 2020-10-15 10:22:26.860595123 +0200
+@@ -18,8 +18,33 @@ namespace Composer\Test {
+ use PHPUnit\Framework\Constraint\StringContains;
+ use PHPUnit\Framework\Constraint\TraversableContains;
+
+- if (method_exists('PHPUnit\Framework\TestCase', 'assertStringContainsString')) {
++ if (method_exists('PHPUnit\Framework\TestCase', 'assertFileDoesNotExist')) {
+ abstract class PolyfillTestCase extends TestCase {}
++ } else if (method_exists('PHPUnit\Framework\TestCase', 'assertStringContainsString')) {
++ abstract class PolyfillTestCase extends TestCase {
++ /**
++ * @param string $filename
++ * @param string $message
++ *
++ * @return void
++ */
++ public static function assertFileDoesNotExist($filename, $message = '')
++ {
++ static::assertFileNotExists($filename, $message);
++ }
++
++ /**
++ * @param string $pattern
++ * @param string $string
++ * @param string $message
++ *
++ * @return void
++ */
++ public static function assertMatchesRegularExpression($pattern, $string, $message = '')
++ {
++ static::assertRegExp($pattern, $string, $message);
++ }
++ }
+ } else {
+ abstract class PolyfillTestCase extends TestCase
+ {
diff --git a/composer.spec b/composer.spec
index e2c100f..8377145 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 188d4fffa74861eae5eb875ee396b9f65edcbd89
+%global gh_commit a0ac42ef3f75a06321361f4396564f65ccf0ed95
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -20,8 +20,8 @@
%global run_version 2.0.0
%global upstream_version 2.0.0
-%global upstream_prever RC1
-%global upstream_lower rc1
+%global upstream_prever RC2
+%global upstream_lower rc2
%global symfony_prefix php-symfony
%global symfony_path %{_datadir}/php/Symfony
@@ -312,6 +312,9 @@ exit $ret
%changelog
+* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 2.0.0~rc2-1
+- update to 2.0.0-RC2
+
* Thu Sep 10 2020 Remi Collet <remi@remirepo.net> - 2.0.0~rc1-1
- update to 2.0.0-RC1